Onkyo 777 DTS problem

Discussion in 'AV Receivers' started by David_Jr, Dec 29, 2003.

  1. David_Jr

    David_Jr Supporting Actor

    Joined:
    Sep 20, 2000
    Messages:
    631
    Likes Received:
    6
    Location:
    Hancock, MA - The Berkshires
    Real Name:
    Dave
    After nearly 4 yrs of hiccup free operation I have recently had trouble with the DTS playback on my 777 receiver. When the DTS track is selected from the disc menu, the disc will then start to play, but there will be no sound, no noise of any kind, just silence. I noticed this a couple of weeks ago when I tried playing the DTS track on the Casper DVD. Now it wouldn't play the DTS on the Pirates of The Carribean DVD last night. the Dolby Digital 5.1 track plays flawlessly however. The only other problem I had noticed lately is that the reciever seems to lock onto the DVD digital audio and won't let go of it when you change sources, say to satellite dish. Any chance these problems are related? This receiver was a $1k purchase when new and my wife went along with the idea that it was a long term upgrade (from prologic). Does it sound fixable? If so, where's a good place to take it?

    Thanks
     
  2. ColinR

    ColinR Auditioning

    Joined:
    Dec 29, 2003
    Messages:
    12
    Likes Received:
    0
    I think it worth fixing. You may be surprised and if it is a known problem inherent to the reciever they may fix it for free or very cheap. Worth a call to CS.
     
  3. Charles Gurganus

    Charles Gurganus Supporting Actor

    Joined:
    Mar 2, 1999
    Messages:
    689
    Likes Received:
    0
    Maybe you already double checked the DTS settings with the DVD menu but I would do that. You never know who might have found their way onto the audio menu on the DVD player and maybe somehow turned off the DTS bitstream. It is far fetched but possible
     
  4. David_Jr

    David_Jr Supporting Actor

    Joined:
    Sep 20, 2000
    Messages:
    631
    Likes Received:
    6
    Location:
    Hancock, MA - The Berkshires
    Real Name:
    Dave
    My only audio choices are "2 channel", "PCM" & "Bitstream". The DVD player is an older Toshiba.
     
  5. David_Jr

    David_Jr Supporting Actor

    Joined:
    Sep 20, 2000
    Messages:
    631
    Likes Received:
    6
    Location:
    Hancock, MA - The Berkshires
    Real Name:
    Dave
    Mystery Solved!!!!! It was the digital assignments in the receiver. They were all screwed up. I was wrong. The DD 5.1 did not play flawlessly. I was getting only prologic all this time and didn't realize it. Had already checked the Onkyo website for authorized repair facilities and was going to wait for after the holidays to bring it in. On New Year's Day my sister brought over her new boyfrend for dinner and any first visit to this household includes a demo of "the system". Played my usual demo of the opening of Lost In Space. He was wowed, but I knew something was wrong. It didn't have it's usual punch and floor rattling bass. My wife even told me later that she thought it sounded a little weak. Sooooo, last night my wife and I are getting ready to watch the Two Towers (finally) and I played with the receiver a bit to check the setings and low & behold the movie is playing in PROLOGIC. My receiver is in a closet in back of the family room so I can't see the display while watching a movie. What I figured out after troubleshooting was that the digital assignments were wrong in the receiver. The DVD coaxial digital was assigned to the Video 1 satellite input (the problems WERE related! several months ago a power outage threw off all of my speaker balances, must've changed the digital assignments as well) So after changing all four digital assignments back to where they were supposed to be, I checked it and we are back in glorious DOLBY DIGITAL 5.1!!!!! Two Towers will be my new reference disk!! What thunderous bass. When the monster flapped its wings my windows were rattling!! No other movie has ever rattled the home theater that much, not even close. Thanks guys for your input. It put me on the trail and now it's fixed and it didn't even cost me anything. Hey, another Christmas present!!!!![​IMG] [​IMG] [​IMG] [​IMG]
     

Share This Page