No sound from passive radiator?

Discussion in 'Speakers' started by WaterEC, May 24, 2006.

  1. WaterEC

    WaterEC Agent

    Joined:
    Sep 12, 2005
    Messages:
    32
    Likes Received:
    0
    Just got a pair of Cambridge Soundworks T300 speakers. Found that there is no sound coming out of the very bottom woofer, which I think is a passive radiator. This is true for both speakers. What is wrong? Thanks.
     
  2. Shane Harg

    Shane Harg Second Unit

    Joined:
    Feb 14, 2006
    Messages:
    291
    Likes Received:
    0
    Nothing is wrong. Passive radiators aren't supposed to have sound coming from them. Also known as a "drone cone," they protect your active woofers from long excursion and are used as alternate way to build a bass reflex design. Although there is no magnet or voice coil on passive radiators, they can be tuned to certain frequencies; making them more accurate than ported designs and making them sort of a ported/sealed hybrid.
     
  3. WaterEC

    WaterEC Agent

    Joined:
    Sep 12, 2005
    Messages:
    32
    Likes Received:
    0
    Thanks a lot Shane for your comments, that explains why. By the way I just bought the Panny AE900 projector, also bought a 92" fixed frame screen. Haven't set it up completely, just tested it briefly, couldn't be happier. My wife was also stunned. Usually she is very picky, but this time even she is satisfied.
     
  4. Shane Harg

    Shane Harg Second Unit

    Joined:
    Feb 14, 2006
    Messages:
    291
    Likes Received:
    0

    Nice choice!!!
     

Share This Page