New to HDTV...and I've got questions...

glen_vt

Auditioning
Joined
Apr 24, 2013
Messages
8
Real Name
Glen
Greetings! New to the board...been lurking and reading reviews and such for a while....but now I need to avail myself upon this communtiy for some help...

I just picked up a new 60" Samsung SmartTV and I'm having a few issues that I hope are nothing more than "set-up" ones....

I've hooked up my cable.dvr box, BR player and reciever to the TV with HDMI cables.

The sound is great....the HD channels look terrific....but the BR stufff is really hit-n-miss.

The pictures is jagged, especially during any movement (of characters, vehicles, etc)...it almost looks like "frames" are missing. (I'm probably not describing it very well). I don't see this so much on "regular" TV. The picture looks very "garish"...I've tried several of the different settings....and "standard" seems okay. I've tried to adjust it, but to no real avail.

The e-manual suggested "turning off" any power-saving/eco features...again, that hasn't helped.

It's discouraging to me that watching my "Star Wars" BluRays looked better on my old standard "lamp" TV and on my computer than on this new big screen....

I'm open to suggestions here and appreciate any feedback....thanks!
 

glen_vt

Auditioning
Joined
Apr 24, 2013
Messages
8
Real Name
Glen
I turned off the 24p on the BD player as suggested...that helped a lot with the "jagged" and jumpy look. I just sampled the SW:ROTS disc that was looking really bad before...better now, but still a little funky looking.

Does that THX Optimizer help in getting the picture looking better? I guess the main thing that's throwing me off at this point is how much clearer and better looking the picture is when just watching a regular TV program....
 

mattCR

Reviewer
HW Reviewer
Senior HTF Member
Joined
Oct 5, 2005
Messages
10,897
Location
Lee Summit, Missouri
Real Name
Matt
If your BD player has such an option, make sure it's set to 1080P playback as it's default and only option; if it's trying to scale, then turn off those (720P or whatever output)

Next, on your Samsung Smart TV, it will have a feature called "SmartMotion" or similar. With most Bluray content, turn it off.. or try it both ways. Some people like it, I (and most others I run into) seem to find it VERY distracting on bluray content.

If you've done those things, check and see if your BD player is using any sort of color settings that are not the default.

Doing those things, you should be fine. If BD content still looks wrong, then something is very amiss.
 

Kevin Collins

Owner, from the first state with COVID-19
Owner
Senior HTF Member
Joined
Jan 14, 2007
Messages
4,186
Location
Seattle, WA
Real Name
Kevin Collins
What is the model number of your Samsung. It would be interesting to look at the manual.
 

glen_vt

Auditioning
Joined
Apr 24, 2013
Messages
8
Real Name
Glen
Thanks for the tips, mattCR...I can't find any feature on the TV called "smart motion" or anything similar. Wish I could....

Kevin, the model number on this set is UN60F7100....

I'm going to look on line now and see if I can find any more information. It's just bumming me out that while channel-surfing tonight, I landed on one of the channels showing "Prometheus"...and the broadcast looked light years better than the Blu Ray I bought....sure hope I can figure this out....
 

glen_vt

Auditioning
Joined
Apr 24, 2013
Messages
8
Real Name
Glen
Okay....downloaded the manual for my BR player and found out how to adjust the "source" setting to 1080p and....BAM! What a difference...much better now.

Thanks to everyone for the advice...much appreciated!
 

Forum Sponsors

Forum statistics

Threads
345,181
Messages
4,733,244
Members
141,401
Latest member
Ab1979