Need help with turntable

Discussion in 'Playback Devices' started by CalvinC, Feb 8, 2004.

  1. CalvinC

    CalvinC Stunt Coordinator

    Joined:
    May 15, 2001
    Messages:
    102
    Likes Received:
    1
    Trophy Points:
    0
    I have a Marantz 7300OSE that I am trying to connect my turntable to. The receiver does not have a phono input so I bought a phono preamp. The problem I am having is with the grounding. I connected a ground wire between the turntable and the receiver but Iam still getting a hum. In connecting to the receiver I have tried a screw on the back panel and the am ground with no luck. Any suggestions? Thanks!
     
  2. Lee Distad

    Lee Distad Stunt Coordinator

    Joined:
    Feb 3, 2004
    Messages:
    166
    Likes Received:
    0
    Trophy Points:
    0
    What kind of pre-amp are you using? Might it be the source of the hum?

    I've encountered this with cheaper (
     
  3. CalvinC

    CalvinC Stunt Coordinator

    Joined:
    May 15, 2001
    Messages:
    102
    Likes Received:
    1
    Trophy Points:
    0
    It is a cheapie, bought off ebay for $25.
     
  4. Brian L

    Brian L Cinematographer

    Joined:
    Jul 8, 1998
    Messages:
    2,918
    Likes Received:
    14
    Trophy Points:
    610
    My NAD phono pre-amp requires the TT ground to go to it, not the receiver.

    Do you get the hum if you don't connect the ground wire to anything?

    BGL
     
  5. CalvinC

    CalvinC Stunt Coordinator

    Joined:
    May 15, 2001
    Messages:
    102
    Likes Received:
    1
    Trophy Points:
    0
    It is still there but not as bad.
     

Share This Page