Need help from a networking guru......

Discussion in 'Archived Threads 2001-2004' started by Byron Holston, Dec 10, 2001.

  1. Byron Holston

    Joined:
    Dec 14, 1998
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    I'm having a problem and hopefully someone can help me. Here's the situation.
    I've got three computers hooked up through a Netgear RT314 router. Two desktops (Win 98se and Win 2K pro) and laptop (win 98se). All three are running DHCP with the router as the DHCP 'server'.
    Whenever I power cycle the router and re-boot the computers, the Win 98 machines are unable to 'see' any of the other boxes. (Meanwhile, none of the boxes have trouble getting out over DSL or connecting to the router.) I have to connect from the Win 2K machine to both of the '98' boxes before they are able to 'connect' to one another. I'm mainly just transfering files from one to another, but it drives me crazy having to go through these extra steps.
    [​IMG] Thanks for any help....
    Byron
    http://www.holstononline.com
     
  2. DonRoeber

    DonRoeber Screenwriter

    Joined:
    Feb 11, 2001
    Messages:
    1,849
    Likes Received:
    0
    Trophy Points:
    0
    The router may not be ready to hand out DHCP addresses when then Windows 9X systems need to get one to configure their NetBIOS shares. Try letting the router come up fully before turning the Windows 9X systems on. Windows 2000 is probably taking longer to boot up than the other windows machines, so that may be what is saving you there (or the networking code is written better, which also may be the case).
     
  3. Byron Holston

    Joined:
    Dec 14, 1998
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the reply.

    I did already look into that thought. When I have to power-cycle the router, I usually power cycle the router, wait for the self-test to complete and the WAN connection to become active, then I shut down the PCs wait a minute or so then boot them back up. I still get the same results.

    Can I add or change a setting in my hosts file that would help??

    Byron
     
  4. Bill Catherall

    Bill Catherall Screenwriter

    Joined:
    Aug 1, 1997
    Messages:
    1,560
    Likes Received:
    0
    Trophy Points:
    0
    I think you may have to have all the other computers turned off when you cycle the power on your router. Try that and see if it makes a difference. (The router should be the first and only "computer" turned on when the WAN connection is established. Then bring up all the other computers.)
     
  5. DonRoeber

    DonRoeber Screenwriter

    Joined:
    Feb 11, 2001
    Messages:
    1,849
    Likes Received:
    0
    Trophy Points:
    0
    You mentioned that you're maintaining a hosts file. That'll cause problems if the systems are getting addresses from the DHCP server on the router. If you want to use the Hosts file, either disable DHCP on the router, or permanently assign the systems IP addresses over .32. It works fine on the netgear, as I've set my printer to be .50 and my wireless AP to .51. All of the systems can talk to them fine.
     
  6. Alex_Williams

    Alex_Williams Auditioning

    Joined:
    Dec 10, 2000
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    This is what I would do and sometimes do for my home user customers. Set the routers DHCP range to 192.168.1.100 – 254 then turn DHCP off on your desktop and win9x PC and assign them an IP between 192.168.1.2 – 99. If you do that you can still use DHCP for you laptops and other portable PC. Your other problem with the win9x PC not seeing the other PC’s after reboot can be solved but Mapping a drive to the other PC and set it to reconnect at login, the reason for this is the win9x PC’s do not spend much time searching for other PC’s but if you have a drive mapped to that PC it will search extensively.

    I hope this helps,

    AFW
     
  7. DonRoeber

    DonRoeber Screenwriter

    Joined:
    Feb 11, 2001
    Messages:
    1,849
    Likes Received:
    0
    Trophy Points:
    0
    Alex,

    Good idea. The netgear RT314 router's DHCP range is limited to a 32 address range, which I believe is hardcoded to start at .2. But the same idea applies.
     
  8. Byron Holston

    Joined:
    Dec 14, 1998
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for all the replies. Here's the latest. I tried making sure everything was turned off before firing up the router and then turning on the PCs. It still acted the same way.

    I went ahead and mapped on of the drives from the win 2k machine to the win 98 machine and that seems to have done the trick.

    Thanks for all the help.

    Byron
     
  9. DavePompea

    DavePompea Auditioning

    Joined:
    Dec 10, 2001
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Have you tried waiting for 15 minutes after all 3 computers have booted up ?

    The reason being, is that for 'Workgroup' (non-domain) networks, the computers only send out identifing packets about every 12 minutes. So it can take a while for everyone to see all the others. So if you're changing things, re-booting, not seeing the other computers, changing things, re-booting, ... there hasn't been enough time for a computer to get identifing packets from the others.

    Ok you ask, then why on some Workgroup networks can you see everyone else right after boot up ?

    Answer: There should be one computer on your network that will act as a keeper-of-names by running the Computer Browser service. The other computers on the network remember the address / name of the Master Browser computer and go to it for the addresses / names of the other Workgroup computers. If no Master Browser exists, then each computer must wait for a brodcast from the others before it knows the others exists.

    Sometimes, more than one computer will have the Computer Browser service running, if so then you'll see in the Event Viewer that 'Elections' have been done to determine which computer is to be the Master Browser.

    Another reason for computers to not see each other is if NetBios is enabled on more that one protocol. It can be bound to IPX, NetBEUI and TCP/IP. If different computers have NetBios enabled on multiple protocols, then that could also cause the problem.

    Along with Netbios, you'll see that you can enable the 'Client for Microsoft Networking and File' and 'Print Sharing for Microsoft Networks' for each protocol. Again, have it enabled for only one, namely TCP/IP for speed, or if your using a cable modem or dsl and don't have a hardware firewall, use NetBEUI as NetBEUI is non-routable and won't get out of your house.

    And last but not least, each protocol that's installed can be set to the Default Protocol. Check each computer to see it's the same.

    Conclusion: Have only one protocol that 'Client for Microsoft Networking and File' uses and that the Computer Browser service is running on one computer.

    Hope that helps,

    Dave
     

Share This Page