My sub is humming....

Discussion in 'Home Theater Projects' started by Greg Yeatts, Nov 2, 2003.

  1. Greg Yeatts

    Greg Yeatts Second Unit

    Joined:
    Feb 26, 2002
    Messages:
    300
    Likes Received:
    0
    My subwoofer is humming. It is even humming when my system is off. About three days ago I came home from work and my BFD was displaying the letters AA something or other (I should have written it all down) in the display. I didn't think much about it. I turnrf the BFD off. I turned the BFD on this evening and my sub was humming. As stated above, it hums even when the receiver is off, but not when the BFD is off. Does this mean my BFD is fried? I did make one change to my system before turning on the BFD. I hooked an Xbox into the system using a Toslink cable and component video. TIA
     
  2. Denis P

    Denis P Extra

    Joined:
    Aug 2, 2003
    Messages:
    24
    Likes Received:
    0
    Sounds like a ground loop. You could have picked it from the ground on you XBox component video cables. Disconnect everything and connect your system pisece by piece. Chances are you will your hum returns when you connect one piece. The solution will depend on exactly what causes it. Take a look at the Jensen isolation transformer or ebtech site for some additional info and some solutions that may help.

    btw: The new subamp is humming too. I've just ordered the Ebtech hum eliminator to isolate the audio connection into the amp.
     
  3. TimForman

    TimForman Supporting Actor

    Joined:
    Dec 4, 2002
    Messages:
    847
    Likes Received:
    0
    I had a hum a while back. It was coming through the cable TV decoder. I had the cable provider come out and correct it, no charge.
     
  4. Dan Wesnor

    Dan Wesnor Second Unit

    Joined:
    Apr 28, 1999
    Messages:
    389
    Likes Received:
    0
    It doesn't know the words. [​IMG]
     

Share This Page