More HL2 problems, this time with TCP/IP

Discussion in 'Gaming' started by Timon Russo, Dec 9, 2004.

  1. Timon Russo

    Timon Russo Stunt Coordinator

    Joined:
    May 10, 2000
    Messages:
    213
    Likes Received:
    0
    Trophy Points:
    0
    So I finally replaced my old 10Mbps 4-port hub with a new Linksys Wireless-B broadband router. I plugged my 2 wired PCs in the back (I don't have a highspeed internet connection yet) and made the 1 change required to get the computers talking: Obtain an IP address automatically. This is the what the instructions said. Previously, I had specified IP addresses for the 2 PCs on the network. Now, when I launch HL2, it takes forever, then gives me a box that says "Updating steam..." and never does anything. There is a cancel button. I can cancel and launch Steam directly, but nothing happens (although it DOES launch a process...).

    I finished the game twice, and I wonder if I should be continuing to spend so much time trying to get my totally-legitimate and over-priced game to continue running. But if you could humor me and tell me how I might get around this, I would appreciate it. Or is there a Steam setting, or (gasp) hack that would help me out here?
     
  2. Tom Keels

    Tom Keels Stunt Coordinator

    Joined:
    Aug 11, 1999
    Messages:
    166
    Likes Received:
    0
    Trophy Points:
    0
    You may have to do some port forwarding on your router. I did and it made a world of difference. But mine worked before I did it to. Is it possible that your router is blocking access to the port that steam uses?
     

Share This Page