Monster Subwoofer PowerCenter SW200?

Discussion in 'Archived Threads 2001-2004' started by Paul Arnette, Feb 13, 2003.

  1. Paul Arnette

    Paul Arnette Cinematographer

    Joined:
    Jul 16, 2002
    Messages:
    2,616
    Likes Received:
    0
    Hello.

    I recently purchased Monster's High Performance Subwoofer PowerCenter SW200 unit. I had an electrician install a properly grounded outlet and attach the device to it.

    I have run the power cable from my Velodyne HGS 12 subwoofer to the High Performance Subwoofer PowerCenter SW200. The subwoofer has its power set initially to "auto".

    At that point, the light is lit indicating "Ground OK", but the "Protection On" light is not lit. When I switch the subwoofer's power from auto to "on", the "Protection On" light still does not light up.

    Is there something I am missing? A switch or feature on the unit itself I need to activate in order to get the "Protection On" light to come on?

    I was looking at it this morning, but I had to get into work, so I thought I might be able to save myself sometime if anyone had had some experience with this unit before.

    Your help is greatly appreciated.

    Thank you.
     
  2. ricky ho

    ricky ho Stunt Coordinator

    Joined:
    Apr 7, 2002
    Messages:
    55
    Likes Received:
    0
    Hey Paul
    I had a similar experience with a monster power item.
    I purchased a monster HTS 5100. The blue diode for clean power worked once. I emailed monstercable.com explained the problem.They told me that the unit was working but the diode must have burned out. I sent the unit back to them and received a new one. No problems since.
    I bought the unit online, therefore had to mail it back at my expense. They paid for shipping the new unit to me.
    I would suggest that if you bought your unit local to return it for a new one. Other wise email monster power for instructions. Good luck.
     
  3. Chu Gai

    Chu Gai Lead Actor

    Joined:
    Jun 29, 2001
    Messages:
    7,270
    Likes Received:
    1
    might be easier and cheaper to just pull that diode out, find out what it is, and then just buy several diodes. i once had a scientific instrument that was always burning diodes out every few months. bought a slew of them from Newark Electronics.
     
  4. Paul Arnette

    Paul Arnette Cinematographer

    Joined:
    Jul 16, 2002
    Messages:
    2,616
    Likes Received:
    0
     
  5. Bill Kane

    Bill Kane Screenwriter

    Joined:
    Feb 5, 2001
    Messages:
    1,359
    Likes Received:
    0
     
  6. Paul Arnette

    Paul Arnette Cinematographer

    Joined:
    Jul 16, 2002
    Messages:
    2,616
    Likes Received:
    0
     
  7. Bill Kane

    Bill Kane Screenwriter

    Joined:
    Feb 5, 2001
    Messages:
    1,359
    Likes Received:
    0
    [​IMG]
     
  8. Neil Joseph

    Neil Joseph Lead Actor

    Joined:
    Jan 16, 1998
    Messages:
    8,332
    Likes Received:
    1
    Real Name:
    Neil Joseph
  9. Chu Gai

    Chu Gai Lead Actor

    Joined:
    Jun 29, 2001
    Messages:
    7,270
    Likes Received:
    1
    btw, you can usually buy the LED's in a slightly higher voltage. means they won't burn as bright but likely last longer.
     
  10. Paul Arnette

    Paul Arnette Cinematographer

    Joined:
    Jul 16, 2002
    Messages:
    2,616
    Likes Received:
    0
     
  11. Paul Arnette

    Paul Arnette Cinematographer

    Joined:
    Jul 16, 2002
    Messages:
    2,616
    Likes Received:
    0
     
  12. Bill Kane

    Bill Kane Screenwriter

    Joined:
    Feb 5, 2001
    Messages:
    1,359
    Likes Received:
    0
    bizarro?

    hmmm. I think "Monstero"
     
  13. Chu Gai

    Chu Gai Lead Actor

    Joined:
    Jun 29, 2001
    Messages:
    7,270
    Likes Received:
    1
    get thee a ciruit tester for $10 and check all your outlets. might be a poorly wired receptacle.
     
  14. Mike Matheson

    Mike Matheson Second Unit

    Joined:
    Jul 15, 2000
    Messages:
    416
    Likes Received:
    0
    Bill, you crack me up. [​IMG]
     
  15. Paul Arnette

    Paul Arnette Cinematographer

    Joined:
    Jul 16, 2002
    Messages:
    2,616
    Likes Received:
    0
    Not that I believe all that many people were following this thread, but I thought I would let everyone who was involved with it know how it turned out.

    In the end, I had Monster send me a new unit, which is now working fine. So, I guess, in the end I got a unit with a bad LED perhaps.

    Anyway, thanks to everyone who assisted me in troubleshooting this.
     

Share This Page