Marantz USA, tech support for receivers?

Discussion in 'AV Receivers' started by ericLee, May 5, 2003.

  1. ericLee

    ericLee Stunt Coordinator

    Joined:
    Oct 15, 2002
    Messages:
    135
    Likes Received:
    0
    Does anyone know the email address for Marantz USA customer service, or tech support? should i even bother, do they actualy respond to emails? this is regarding the x200 receivers so i guess this is the right place to post. I looked all over the marantz site but the only email I could get is [email protected], which I tried about a month ago and no response, just an automated thing from the webmaster saying the email is undeliverable. Also does anyone have an email address for Service Wide Tech, there repair center? I could just call them but I don't fell like waiting on the phone for an hour. thanks for reading my post.[​IMG] [​IMG] have some Popcorn! I finaly sent my 6200 for service and put in my pioneer vsxd510(2yearoldmodel) also sold in ratshack for like 100buck. And WoW, sounds better than the 6200+ chiro c-300+ the 300bucks in cabeling. WoW just got through the martix and the bass is finaly there on Dolby sources. My marantz is relly doing some funky things to my signals.
     
  2. ericLee

    ericLee Stunt Coordinator

    Joined:
    Oct 15, 2002
    Messages:
    135
    Likes Received:
    0
    I found the feedback form on marantz.com and did that and just got an auto response that said call them. It's a 609 number, hope long distance isn't to expensive because i'll be on the line forever.[​IMG]
     
  3. Aaron_Morris

    Aaron_Morris Stunt Coordinator

    Joined:
    Jul 1, 2002
    Messages:
    106
    Likes Received:
    0
    If you do call Service wide, they are pretty good about answering the phone (as long as they are actually there, they take more days off, I swear) and getting you the answer you are looking for or passing you on to where you need to go.
     
  4. ericLee

    ericLee Stunt Coordinator

    Joined:
    Oct 15, 2002
    Messages:
    135
    Likes Received:
    0
    I called SWTech yesterday and I got an auto promp, which says they close at 4:30 but when I checked the time it was 3:00 pm eastern so in that timezone it would be like 2:30. Guess they must be very very busy fixing all the messed up X200, X300, vps1's, etc, etc. I'll try again today but i think i'll get a messege. [​IMG]
     
  5. ericLee

    ericLee Stunt Coordinator

    Joined:
    Oct 15, 2002
    Messages:
    135
    Likes Received:
    0
    I don't think i'll have a chance to call SWTech today maybe tommorow. But I could wait since the old pioneer does sound better without the constant poping, thumping and you can actualy hear the menues and the begining of songs. My SVS is finaly sounding like it should too. There's so many things wrong with the unit (8 compaints so far) I relly doubt they could even fix it completly. That would relly piss me off if i had to put down another 30 dollars to send it in again. This would be there 2nd time fixing it because it was a refurb and was supposedly fixed the first time, If the little inspection sheet they include with the refurb is correct. They even put stickers all over the box that say QC passed, inspected by marantz:wink: But it is kinda my fault for not sending it right back at AC4L, since the inspection sheet was ripped and the packing was shaddy. But i learned that you should never trust a company even if they have a good rep, If it looks kinda fishy, send it back right away. At the time this was my most expensive audio purchase ever and I didn't want to 'admit' that i made a bad purchase. plus i'm still in college and 30 bucks for shipping is still a lot of money to me. But also AC4L should have known better and not try to recylcle a bad unit for me to deal with.
     
  6. Aaron_Morris

    Aaron_Morris Stunt Coordinator

    Joined:
    Jul 1, 2002
    Messages:
    106
    Likes Received:
    0
    I know exactly how you feel. I am in the same boat with my 5200. Came in and didn't work at all. Sent it in, (payed shipping because UPS never caem by to pick it up) got it back and the front left channel didn't work. Sent it back, made sure they paid shipping this time. Haven't gotten it back yet, but I will let you know how it turns out.

    As long as it is within the first year, they will warranty the parts and labor, but not the shipping if it isn't a problem when you first recieve it. The fact that I reported the problem and just put up with it for a few months is the only reason they agreed to pay for shipping this time.
     
  7. ericLee

    ericLee Stunt Coordinator

    Joined:
    Oct 15, 2002
    Messages:
    135
    Likes Received:
    0
    -AaronM
    I wish I had an obvious problem aside from the poping and other common issues. But I had this unit for 8 months not knowing that was something very wrong with it. It appeared to work Ok but when i finaly checked vs 2 older and much cheaper AVRs it sounded worse. It's kinda like a silent problem, It would be very hard for anyone to tell it was messed up, especialy using the HTIB i had when i first got it. I fell cheated because I spent so much trying to make my system sound decent but It never did. I upgraded and tried everything- 2 new subs, 2 dvd players, 3 coaxial cables, 2 sub cables, monster power filter, 2 sets of speakers, seperate amp, new interconnects and new speaker cableing. I never suspected the marantz to be the problem. I was eventualy going to upgrade my system but I would always be instantly dissapointed after every upgrade and i constantly had to upgrade, it was a very sad and bad sounding year, All because of AC4L and Marantz.
    I was even thinking about returning my SVS! Which now rocks with my cheapo Pioneer.
     
  8. Aaron_Morris

    Aaron_Morris Stunt Coordinator

    Joined:
    Jul 1, 2002
    Messages:
    106
    Likes Received:
    0
    Well, hind sight is 20/20 and all, but...
    When ever you get a new peice of equipment that you have dome some research, you really ought to compare it will something else that is of decent quality. If it is not living up to your expectations then have it switched. AC4L does have an exchange policy for this very reason. You sure went through a lot of equipment to find the problem. But I am not judging you for that. Just chaulk it up as a learning experiance.
     
  9. ericLee

    ericLee Stunt Coordinator

    Joined:
    Oct 15, 2002
    Messages:
    135
    Likes Received:
    0
    I called SWTech yesterday, and they said it was coming on the 9th. I tried to ask for more info, but they were kinda rude and gave me some attitude, so I'll have to wait till i get it to see if it's OK. I also have black hawk down DTS coming today also, I'll post with results. I relly hope they get it right this time.
     
  10. Aaron_Morris

    Aaron_Morris Stunt Coordinator

    Joined:
    Jul 1, 2002
    Messages:
    106
    Likes Received:
    0
    Eric, I just got my 5200 back today and it seems to be working fine now. Good thing, as finals are pretty much over for me, so now I can get a week or two of good quality movie watching in before I have to start full time work and a summer class or 3. [​IMG]
     
  11. ericLee

    ericLee Stunt Coordinator

    Joined:
    Oct 15, 2002
    Messages:
    135
    Likes Received:
    0
    update-
    Got the receiver back on the 9th, listen about 10 hrs this weekend. Big dissapointment, Nothing relly was fixed. Still sounds like crap. here's my observations:

    pop/thumping- there's no poping but since i added the HK dvd 25 there was no poping anyway. Theres still some audio drop out and more importantly the thumping from my chiro amp is still there, no change.

    s-video noise- only happens in the OSD now but it's now more visable in the osd. before there was slight noise, no it constantly pulses every 5 seconds on/off in the OSD.

    High noise- At first it appears the noise is reduced but I also noticed that the signal level is also reduced, so i now have to crank to -00 instead of the -10 i used to, It's even more noisey at -00. No change at all.

    Music sound- Still sounds bad. testing vs Pioneer, Pioneer was easy to listen to less harsh, more full, better bass

    Movie sound- sounds bad. Pioneer bass is very good also bass mang is better with Pioneer. Marantz does have an edge in only high detail, but this also makes it easily harsh and grating to listen too. Pioneer just sound better, with less fatige. I used to think the Pioneer was underpowered but compared to the marantz it seems to have more power.

    The only + about service wide tech is they gave me new styrfoam and peanuts. The peanuts were very colorful and with so much variety, some looked like puffed cheese doodles, and looked very tasty. But other than that it was very dissapoiting. I don't have the money right now to send it yet again to them, and plus I doubt they could actualy fix it. I think I'll contact Marantz directly see if they could help me. I'm plannig on emailing them, snailmail and fax just in case I get ignored. Oh, on the report sheet SWT filled out they said they "fixed" the OSD/svideo board and replaced main in/out board. [​IMG]
    Now i'm pissed..
     
  12. Aaron_Morris

    Aaron_Morris Stunt Coordinator

    Joined:
    Jul 1, 2002
    Messages:
    106
    Likes Received:
    0
    That is sad to hear. I'd be pissed too if it came back not working. I think Service wide will pay shipping this time since it was not fixed. Make sure to include a problem description when you send it in.

    I'd contact AC4L and tell them that it still doesn't work correctly. I doubt they will give you a refund, but they might be willing to send you a differant unit. Be polite but firm and you just might get your way.

    Deffinately call service wide tech and tell them about the problem though.
     
  13. ericLee

    ericLee Stunt Coordinator

    Joined:
    Oct 15, 2002
    Messages:
    135
    Likes Received:
    0
    I'll hold off on SWT until I speak with someone at Marantz America first to see how that goes.
     
  14. ericLee

    ericLee Stunt Coordinator

    Joined:
    Oct 15, 2002
    Messages:
    135
    Likes Received:
    0
    -update-
    talked with someone from Marantz
    they inturn contacted SWT, SWT gave me a Prepaid label to send it in to get evaluated. I'm sending it tommorow and will have to wait another month. At least their paying for shipping this time. But why didn't they 'evaluate' it when they had it a weeks ago?
    I wonder if the'll actualy fix it compleatly this time.
     
  15. ericLee

    ericLee Stunt Coordinator

    Joined:
    Oct 15, 2002
    Messages:
    135
    Likes Received:
    0
    [​IMG] [​IMG] [​IMG] [​IMG] -This is not looking good so far. I called up SWT today and guess what I got the same person on the phone as i got last time except he gave me more of an attitude and the bastard laughted at me when i asked him a question. he gave me such an atitiude i felt like to curse the prick off, but unfortunatly he put me on hold while i was still talking and i hung up. He said he's been running my reciever since the 19th and he's had absolutly no problems with it. What the hell are these guys at SWT smoken? now i've had it. fixed or not fixed the Marantz has got to go
     
  16. ericLee

    ericLee Stunt Coordinator

    Joined:
    Oct 15, 2002
    Messages:
    135
    Likes Received:
    0
    Update-
    Finaly!
    after 6 weeks of waiting it looks like i'll be gettting a replacment. Its been a long and frustrating 6 weeks. The people at Marantz relly need improve there customer support. It should not have taken this long. I can't wait to test it out. BTW they said there shipping a 6300 instead of a 6200 so i might keep it instead of my prevous idea of selling it. This whole experiance has made me warry of not only marantz products but also buying online. A good dealer can end up saving you a whole lot of frustration and time even if the price is a little more. thanks for reading my post.[​IMG]
     

Share This Page