1. Sign-up to become a member, and most of the ads you see will disappear. It only takes 30 seconds to sign up, so join the discussion today!
    Dismiss Notice

Marantz 5300 problem

Discussion in 'AV Receivers' started by Tamer C, Aug 18, 2003.

  1. Tamer C

    Tamer C Agent

    Joined:
    Apr 25, 2003
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    0
    Hi everyone,

    I just purchased a Marantz 5300. After connecting just the fronts and center speakers, I connected the power to the receiver to try it out. There was nothing on the display. I could see the power light go on and off when I press the power switch, and also when I switched inputs I would here a click. but nothing on the display.

    I tried resetting the receiver by pressing dimmer and a/d, and also playing with the dimmer and night buttons. Anyone know what could be going on? Is this unit defective?

    Thanks
     
  2. John Garcia

    John Garcia Executive Producer

    Joined:
    Jun 24, 1999
    Messages:
    11,571
    Likes Received:
    25
    Trophy Points:
    0
    Location:
    NorCal
    Real Name:
    John
    Sounds like it was damaged in shipping. Hopefully you bought it locally. If so, take it back and have them exchange it for one that works, and if possible, ask them to open it up to test it first.
     
  3. Tamer C

    Tamer C Agent

    Joined:
    Apr 25, 2003
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the reply.

    Yeah luckily I bought it locally. I will go exchange it tomorrow. I was just hoping there could be something I could try.
     

Share This Page