What's new

Lots of humming (1 Viewer)

Shane Morales

Second Unit
Joined
Jul 9, 2003
Messages
443
Hi. I use an old (16 years?) Denon AVR 8303 receiver with my computer. It's always worked fine for me. But recently there's been a lot of humming coming from the speakers, especially when I turn up the volume. Is this the receiver? Is it going bad?

Thanks.
 

JohnRice

Bounded In a Nutshell
Premium
Reviewer
HW Reviewer
Senior HTF Member
Joined
Jun 20, 2000
Messages
18,844
Location
A Mile High
Real Name
John
What sources is it connected to, and how are they connected? Did you add a new source recently? Is it connected to any kind of cable TV source?
 

Shane Morales

Second Unit
Joined
Jul 9, 2003
Messages
443
My setup: Windows 10 PC via USB Sound Blaster HD (analog) > receiver > speakers/powered-sub. No new sources, and no cable service. It used to work just fine, but now... lots of humming.

Thanks.
 

JohnRice

Bounded In a Nutshell
Premium
Reviewer
HW Reviewer
Senior HTF Member
Joined
Jun 20, 2000
Messages
18,844
Location
A Mile High
Real Name
John
Does the volume of the hum change as you change the volume on the receiver, or does it stay the same? Is it on just one input on the receiver, or on all of them?
 

Shane Morales

Second Unit
Joined
Jul 9, 2003
Messages
443
Doesn't matter now. The receiver blew up today. Heard a big pop and then there was smoke and stuff and it died.
 

JohnRice

Bounded In a Nutshell
Premium
Reviewer
HW Reviewer
Senior HTF Member
Joined
Jun 20, 2000
Messages
18,844
Location
A Mile High
Real Name
John
Well, that was probably why it was humming. :laugh:
 

Mike Frezon

Moderator
Premium
Senior HTF Member
Joined
Oct 9, 2001
Messages
60,611
Location
Rexford, NY
giphy.gif
 

Users who are viewing this thread

Forum statistics

Threads
356,565
Messages
5,116,092
Members
144,112
Latest member
absplumbing
Recent bookmarks
0
Top