lord of the rings outputting only 2.0?

Slaternator

Auditioning
Joined
Dec 25, 2006
Messages
2
Real Name
Neil Slater
G'day guys.
I've recently installed a Sony system that has 2 X optical inputs and a coax input.
My current DVD player has only a coax or analog 5.1 out so I hooked it up via the coax (digital).
Saving private ryan slips into DTS no problems and sounds fantastic, but it will not do Lord of the rings, which is Dolby Cinema surround EX (6.1). It only pumps out (or detects) 2.0 (2 channel).

A few things:
1. I've enabled the sound on the DVD menu
2. I've tried to force 6.1 via the amp menu - no good
3. the DVD samples at 48khz and 96khz - currently set at 96 - should it be anything else? eg: disabled, 48 or whatever?
4. are there any DVD player settings that are not compatible with cinema surround EX (I think it is THX or a derivative of it).
5. is it possible that the DVD player is not compatible with the sound decoding?
6. the receiver detects the coax in both movies ie: it is not prioritising the analog in over the coax for lord of the rings.

thanks in advance, NS
 

Michael Reuben

Senior HTF Member
Joined
Feb 12, 1998
Messages
21,763
Real Name
Michael Reuben
Moved to Receivers. The Movies forum is for discussion of movies, not equipment problems or DVD features. The forum descriptions are helpful in determining where a thread belongs.

M.
 

Slaternator

Auditioning
Joined
Dec 25, 2006
Messages
2
Real Name
Neil Slater
stop the bike!
ok, found a setting in the DVD player: SPDIF/Raw or SPDIF/PCM
turns out PCM is 2.0
flicked it to RAW and all good!


Cheers, NS
 

Forum Sponsors

Forum statistics

Threads
344,920
Messages
4,724,766
Members
141,359
Latest member
truvalastavi