Linux: clock trouble

Discussion in 'Archived Threads 2001-2004' started by Bill Catherall, Nov 20, 2001.

  1. Bill Catherall

    Bill Catherall Screenwriter

    Joined:
    Aug 1, 1997
    Messages:
    1,560
    Likes Received:
    0
    Having recently installed Linux Mandrake 8.1 I've been having a bit of trouble with the clock. For some reason Linux insists that the hardware clock is set to GMT. So when I'm using the KDE GUI the clock is 8 hours behind (having set the time zone to PST). If I correct the time then it changes the hardware clock. The solution: Change the hardware clock to GMT. The problem: I'm running a dual boot system and the clock in Win98 uses the same time as the hardware clock, regardless of time zone. So either the clock in KDE is wrong all the time or the clock in Windows is wrong all the time.

    When I use the Gnome GUI then it's easy to fix because I just set it to read the GMT time and it shows the hardware clock time. But KDE doesn't have this ability. I'd have to set the timezone to be GMT. I'd do that but you have to select cities from a list. You can't just select a timezone and I can't find a city on that list that is in the GMT timezone! I'd hate to abandon KDE just because of the clock, is there some solution to this madness?
     
  2. Alan Curry

    Alan Curry Agent

    Joined:
    Aug 5, 2001
    Messages:
    47
    Likes Received:
    0
    Try setting the clock through DrakConf i.e. Mandrake Control Central. It should ask you if your clock is set to GMT. Select no. To set the time zone, select a city within your time zone.

    Hope this helps.

    Alan
     
  3. Bill Catherall

    Bill Catherall Screenwriter

    Joined:
    Aug 1, 1997
    Messages:
    1,560
    Likes Received:
    0
    Thanks Alan. I'll give it a try when I get home tonight.
     
  4. Alan Curry

    Alan Curry Agent

    Joined:
    Aug 5, 2001
    Messages:
    47
    Likes Received:
    0
    Bill
    I was wrong above. It should ask for the GMT after you have selected your city.
    Alan
     
  5. Bill Catherall

    Bill Catherall Screenwriter

    Joined:
    Aug 1, 1997
    Messages:
    1,560
    Likes Received:
    0
    Yep, that's what it did and it fixed the problem. I didn't even think of using the Mandrake Control Center. I was just using the KDE Configuration control and that wasn't giving me the option of turning off hardware GMT time.
    Thanks again.[​IMG]
     
  6. Alan Curry

    Alan Curry Agent

    Joined:
    Aug 5, 2001
    Messages:
    47
    Likes Received:
    0
    Bill,
    Great! Glad to hear it. I'm glad that worked for you.
    Have a good evening.
    Alan
     

Share This Page