JVC XV-S65 Any fix for ep. I subtitle glitch yet?!

Discussion in 'Archived Threads 2001-2004' started by John C, Jan 13, 2002.

  1. John C

    John C Stunt Coordinator

    Joined:
    Mar 3, 2000
    Messages:
    82
    Likes Received:
    0
    Trophy Points:
    0
    Hello all. Yesterday I purchased the very nice JVC XV-S65 unit and discovered almost immediately the Star Wars Episode I subtitle problem while testing the player out on various discs. I've seen on previous threads that nobody has had much luck in getting anything out of JVC as to whether a firmware workaround was forthcoming. Also, Fox doesn't seem to know much about this issue either. Has anyone heard anything from either camp on this issue?

    Second question. I have a 4 year service contract on the unit from Best Buy. I would take it back immediately but really like the unit in all other respects. After reading fellow HTers reviews I don't want a unit from another company. Does anyone know if I tried to exchange it when a newer JVC model comes out around the same price range (hopefully with a fix for the sub prob), what my luck would be?
     
  2. James Peench

    James Peench Auditioning

    Joined:
    Jun 18, 2001
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    I recently read a thread from someone who had the 90BK (w/ DVD-Audio) and had the same problems. He finally got someone at JVC to admit to the problem. Someone at JVC actually called him back and asked him to ship the unit to them for an upgrade.
    I don't think he has it back yet so I'm not sure what they are planning to do, but I would recommend that you contact JVC, be persistent, ask to speak to a supervisor or whatever until you get someone who knows what's going on and then get an address where you can ship it for upgrading.
    Good luck! [​IMG]
     

Share This Page