1. Sign-up to become a member, and most of the ads you see will disappear. It only takes 30 seconds to sign up, so join the discussion today!
    Dismiss Notice

Impedence problem with pro amps and recievers?

Discussion in 'Archived Threads 2001-2004' started by Greg P, Feb 8, 2002.

  1. Greg P

    Greg P Stunt Coordinator

    Joined:
    Jan 7, 2001
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    0
    This is a subject Im really clueless about and will probobly need help. Some new SVS+ owners are having problems with the impedence from the recievers sub out and the pro amps. I am building a diy sub and am going to use a pro amp to power it. I also use a Denon reciever which supposively has a very low impedence siganl which I think is not good. Can someone educate me on this topic and tell me what to do if I run into this problem with my amp/reciever choice?

    Thanks,

    Greg
     
  2. Vince Maskeeper

    Vince Maskeeper Producer

    Joined:
    Jan 18, 1999
    Messages:
    6,499
    Likes Received:
    0
    Trophy Points:
    0
    I wouldn't worry about it too much. There are a few solutions if you run into it. I'd bet $1 you won't.

    -Vince
     
  3. jeff lam

    jeff lam Screenwriter

    Joined:
    Jun 4, 2001
    Messages:
    1,798
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    San Jose, CA
    Real Name:
    Jeff Lam
    Greg,
    You are about 18 minutes behind[​IMG]
    See my post, states pretty much the same thing you are asking.
     
  4. Vince Maskeeper

    Vince Maskeeper Producer

    Joined:
    Jan 18, 1999
    Messages:
    6,499
    Likes Received:
    0
    Trophy Points:
    0
    It is rare that this is an issue, and I think the SVS issue is one that is getting blown out of proportion because of some ignorance of electrical/audio concepts by some of the posters.
    Please see my most recent post:
    http://www.hometheaterforum.com/htfo...337#post427775
    -Vince
     

Share This Page