What's new

Help with using Sony STR‑DN840 with Sony XBR 75X900E (1 Viewer)

Tony TerBorg

Auditioning
Joined
Jun 26, 2018
Messages
8
Real Name
Tony TerBorg
I recently purchased the XBR 75X900E and love the picture but am having a few issues with sound and communication when integrating it with my STR-DN840 receiver. System at this point is really simple. Samsung Blu-Ray player hooked via HDMI to receiver. HDMI out of receiver to HDMI input on display (I've used all four inputs), optical out from display to SAT/TV input on receiver.
1. When I use my Blu-Ray player, I get great 5:1 sound and picture but when I go to adjust volume, it pauses the DVD player for a 2-4 seconds before it kicks back in. (FYI - With previous LG display, I did not have this issue)
2. When I use stream audio from my TV (Netflix, HBO, Hulu, etc) to the receiver, and then go to change the volume on the receiver, it changes the input on the TV to the HDMI port being fed out of the receiver. I then have to rest everything. Only way around this issue so far is to disconnect the HDMI cable from the TV input when streaming.
3. No matter what I try, I cannot seem to get 5:1 surround out of the TV. Specs indicate the optical will send 5:1 and I have tried several streaming signal sources that state 5:1 is being sent. I have also made sure TV is set to output 5:1.

Any thought on any of the above issues would be appreciated in helping work out the bugs in the setup.
Thanks. Tony
 

xx Brian xx

Stunt Coordinator
Joined
Dec 18, 2017
Messages
237
Real Name
Brian
Since you are not using ARC, I would disable CEC to see if that fixes the first two items. Go into: Home > Settings > External Inputs > Bravia Sync Settings and turn it off. See if that helps. Also, what are you using for a remote? TV remote, Harmony, etc.


Brian
 

Tony TerBorg

Auditioning
Joined
Jun 26, 2018
Messages
8
Real Name
Tony TerBorg
Hi Brian,
I will give that a try and report back. Currently I am just using the devices remotes till I get bugs worked out, then will go to my Harmony. It might be worth adding the first two issues happen even if I just manually turn volume knobs or source selector on AV receiver.
Thanks for responding.
T
 

Tony TerBorg

Auditioning
Joined
Jun 26, 2018
Messages
8
Real Name
Tony TerBorg
Just a followup, turning the sync off did correct the issue with 1 and 2. Thanks. If anyone has any thoughts on the surround issue posed in #3 it would be greatly appreciated. Can anyone confirm that the optical out does pass 5:1 digital?
 

Users who are viewing this thread

Forum Sponsors

Forum statistics

Threads
349,145
Messages
4,869,914
Members
142,492
Latest member
DavieGravy
Recent bookmarks
0
Top