Help with strange sound coming from system?

Discussion in 'Archived Threads 2001-2004' started by Dennis Ellis, Nov 10, 2002.

  1. Dennis Ellis

    Dennis Ellis Stunt Coordinator

    Joined:
    Jan 2, 2001
    Messages:
    73
    Likes Received:
    0
    I am having a problem with my setup. Here's the breakdown.
    Onkyo 575x.
    JBL nsp1 (i think that's the model #) It's 4 sat's, n-center.
    pioneer 302d dvd player.
    sony 10" sub.

    Every so often I have a popping in my speakers. As best as I can tell, it's comes through all of them. It happens about once an hour. I haven't noticed it with dvds but I do not watch alot of dvd's. It really sounds like a "surge" of power followed by a "pop". That's the best I can describe it.
    I have double-checked all connections on the back of the onkyo/speakers.
    I do have the cheap radio shack solderless connections on everything though. Could it be related to that?
    I also have the extended warranty on hte onkyo but hate to send it in so they can send it off, listen to it for 5 minutes and say "Sounds good to me".
    Any suggestions?


    de
     
  2. Mark Zielinski

    Mark Zielinski Auditioning

    Joined:
    Sep 27, 2002
    Messages:
    8
    Likes Received:
    0
    Do you have a decent surge protector? Or do you not have one at all?

    -Mark Zielinski
     
  3. Dennis Ellis

    Dennis Ellis Stunt Coordinator

    Joined:
    Jan 2, 2001
    Messages:
    73
    Likes Received:
    0
     

Share This Page