Help with my Toshiba 32HF73

D. England

Auditioning
Joined
Dec 8, 2006
Messages
2
Real Name
David England
I came home the other night ready to watch some "Must See T.V." only to find the picture on my 2.5 year old Toshiba 32HF73 was "messed up". It has a greyish shading with 1/4 inch white horizontal lines across the screen and the image behind them is out of focus. When I first turn it on, the white lines overpower the image, but after about 5 minutes, the lines fade slightly, but the TV is still unwatchable even after letting run for over 3 hours. The sound it good and the problem persists no matter trying to watch DVD or TIVO after unhooking the cable and trying any number of configurations.

I've read several of the posts on this board and other sights, but I haven't found a definitive answer. The closest to my problem talked about a bad power supply, but there was never full resolution posted.

I'm hoping someone has an idea before I fork out $100 to have it diagnosed and who knows how much to have it fixed.

Thanks in advance!!!
 

DougR

Second Unit
Joined
Jun 15, 1999
Messages
354
Don't know if it would help, but did you try unplugging the set from the wall for a few minutes?
 

D. England

Auditioning
Joined
Dec 8, 2006
Messages
2
Real Name
David England
Thanks DougR. I tried unplugging it for a few minutes and few hours and left it unplugged all night. Nothing seems to work.
 

Forum Sponsors

Forum statistics

Threads
344,914
Messages
4,724,450
Members
141,356
Latest member
gullfo