What's new

Help with my avr 325 (1 Viewer)

Jaimin

Stunt Coordinator
Joined
Aug 4, 2002
Messages
50
Hello everybody,

I just purchased an avr 325 in february and have been really happy with it. But recently I heard fuzzy sound coming from the front right speaker. It has lower volume than the left front and has pops and crackles in the sound, if that makes sense. I tried switching speakers and made sure it wasn't the speaker. So does this mean I have to take this unit in for repair, or are there other things I should check for before I take it in? Also can someone maybe tell me what's wrong with my receiver, is it the processor, the amp, the connection, etc..? Any help is appreciated.

Thanks

Jaimin
 

Jaimin

Stunt Coordinator
Joined
Aug 4, 2002
Messages
50
I would appreciate any help at all, especially as to what the cause of the problem could be. Thanks.
 

JohnSer

Stunt Coordinator
Joined
Dec 4, 2002
Messages
198
Assuming its on all sources, the only thing I can think of is to check the speaker wire connection on the back of the receiver. Make sure no strands are sticking out and touching something.

JohnS
 

Users who are viewing this thread

Sign up for our newsletter

and receive essential news, curated deals, and much more







You will only receive emails from us. We will never sell or distribute your email address to third party companies at any time.

Forum statistics

Threads
357,626
Messages
5,142,611
Members
144,434
Latest member
swethaJK
Recent bookmarks
1
Top