help! my HK AVR320 is going crazy... :(

Discussion in 'AV Receivers' started by Bin_L, Aug 2, 2003.

  1. Bin_L

    Bin_L Auditioning

    Joined:
    Aug 1, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    first off hello all, i'm new here [​IMG]

    My HK AVR320 is having a problem, when turn on it just shuts itself off in like 3 seconds. what can be the problem? I have reset the receiver by pressing the tone & fm mode button and it still does the same. Oh and the other problem is I lost my receipt and probably can't bring it to the service center to be repaired even though its under 1 year....

    Has anybody who owns the avr320 experienced this problem? Thanks
     
  2. Greg Thomas

    Greg Thomas Second Unit

    Joined:
    May 3, 1999
    Messages:
    438
    Likes Received:
    0
    Trophy Points:
    0
    Mine works fine but check your speaker connections. Perhaps there's a loose wire touching the chassis or another speaker terminal. Pull them all out, check for loose strands. I'm not sure if you're using banana plugs or bare wire but that's always the first place to check. Or also if you accidentally reversed polarity on either the terminals or at the speaker.

    I just left mine on for 24 hours accidentally. It was still playing the radio.
     
  3. Bin_L

    Bin_L Auditioning

    Joined:
    Aug 1, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I've pulled out every connection and wires, does the same thing still...
     
  4. RobWil

    RobWil Supporting Actor

    Joined:
    Mar 17, 2003
    Messages:
    733
    Likes Received:
    0
    Trophy Points:
    0
    could just be a faulty switch. maybe you don't need the receipt...could be they have your purchase on record. If you bought it at a place like Circuit City it should be no problem.
     

Share This Page