Help - is my HK520 defective?

Discussion in 'Archived Threads 2001-2004' started by JamesL, May 1, 2002.

  1. JamesL

    JamesL Agent

    Joined:
    Jan 20, 2000
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    0
    I just bought a HK520 and after a few hours of viewing each night there is strong odour (like plastic burning) coming from my receiver. Its been only 6 days - is there a breakin period or something else I should be aware of?

    Thanks in advance.

    James

    Note: the HK520 is not enclosed in a cabinet - it is completely open on all 4 sides.
     
  2. Paul Clarke

    Paul Clarke Supporting Actor

    Joined:
    Jan 29, 2002
    Messages:
    998
    Likes Received:
    0
    Trophy Points:
    0
    How much top clearance? You're sure its more like plastic melting? If the receiver is fully functional and you are experiencing no difficulties it sounds like normal electrical break-in to me.
     
  3. John Garcia

    John Garcia Executive Producer

    Joined:
    Jun 24, 1999
    Messages:
    11,571
    Likes Received:
    25
    Trophy Points:
    0
    Location:
    NorCal
    Real Name:
    John
    Sounds relatively normal to me for a receiver. New electronics that get hot often have that smell for a little while. My TV did it, and so did my receiver. If it KEEPS doing it, I would worry.
     
  4. JohnnyG

    JohnnyG Screenwriter

    Joined:
    Dec 18, 2000
    Messages:
    1,522
    Likes Received:
    0
    Trophy Points:
    0
    I just love that new equipment smell! [​IMG]
     
  5. Rob_Pierce

    Rob_Pierce Second Unit

    Joined:
    Apr 24, 2002
    Messages:
    297
    Likes Received:
    0
    Trophy Points:
    0
    This seems like a very simple solution, but did you remove the very, very thin plastic sheet that covers the face of the receiver? It is very difficult to see and many hk 520 users have not removed this film. This film is also on the two remotes that come with the receiver. Good luck!

    I just bought this receiver a few days ago--it is great!!
     
  6. Paul Clarke

    Paul Clarke Supporting Actor

    Joined:
    Jan 29, 2002
    Messages:
    998
    Likes Received:
    0
    Trophy Points:
    0
    My cover sheets never stay on the remotes for long...they just start bubbling up all over, especially around the inputs. They're only there to protect the few lettered imprints actually on the remote and not on the buttons anyway. I do like keeping the receiver fascia cover on though if there are little fingers around.[​IMG]
     
  7. Bob_Lawrance

    Bob_Lawrance Stunt Coordinator

    Joined:
    Apr 14, 2002
    Messages:
    163
    Likes Received:
    0
    Trophy Points:
    0
    James

    My avr 520 is doing the same thing, after a couple of hours, it starts to smell as well. I figure it does this because it is new, The amp does get a little warm.

    I bought mine in febuary, I don't use it a whole lot right now.

    Does anyone with the smell, how long did the smell last?
     
  8. John_VI

    John_VI Second Unit

    Joined:
    Feb 18, 2002
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    0
    Mine is also pretty new, but I haven't noticed that kind of a smell....yet. OMG, now I have to check for the smell!!

    Thanks a LOT, JamesL!!! Something ELSE for me to worry about!!

    LOL!
     
  9. John_VI

    John_VI Second Unit

    Joined:
    Feb 18, 2002
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    0
    Sorry. Duplicate post.
     
  10. Earl Simpson

    Earl Simpson Supporting Actor

    Joined:
    Jan 12, 2002
    Messages:
    803
    Likes Received:
    0
    Trophy Points:
    0
    Better check you speaker ohms. Some faulty crossovers have fried amps to a pure black state. Are you using 8 ohm speakers????????????????????? An electronic burning smell is not normal. New paint is! Is your rcvr hot to the touch or very warm. If it is , Houston we have problems.
    Good luck. It's under warranty, so don't sweat too much.[​IMG]
     
  11. DonJ

    DonJ Second Unit

    Joined:
    Mar 5, 2002
    Messages:
    293
    Likes Received:
    0
    Trophy Points:
    0
    Yeah when I got my 320 I had that same smell. I was so worried at first that I didn't even leave it in standby. I even switch the power off when I went to work.
     

Share This Page