Help...I need a cable guy!!!

Discussion in 'Archived Threads 2001-2004' started by RoyB, Oct 21, 2002.

  1. RoyB

    RoyB Extra

    Joined:
    Jan 22, 2002
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    0
    My cable reception suddenly turns "snowy" while I'm watching TV. It is much more pronounced in the lower number channels. I can fix the problem by undoing the connection from the wall and putting it back together...but it only works temporarily. The picture becomes "snowy" again.

    I noticed the connector on my cable coming out of the wall was loose so I replaced it with a Radioshack gold-plated version but the problem is still there.

    Any ideas why the picture reverts spontaneously like that? Is the little central wire too long? Is it a shielding problem? Do you think I installed the connector wrong? Do I need to replace the splitter box that the cable goes into?

    I appreciate the help...I'm tired of going behind my set to reconnect every 15 minutes!!

    Equipment:
    JVC AV31BP6 31" direct view single tuner PIP
    Cable from wall goes into splitter box so I can use my VCR as second tuner.
     
  2. Neil Joseph

    Neil Joseph Lead Actor

    Joined:
    Jan 16, 1998
    Messages:
    8,332
    Likes Received:
    1
    Trophy Points:
    0
    Real Name:
    Neil Joseph
    If you wiggle the cable around while watching the TV, does the picture alternate between snowy and normal? Another thing that may help is spraying contact cleaner on the ends of the coax RG-59 cable and the connector on the back of the TV.
     
  3. RoyB

    RoyB Extra

    Joined:
    Jan 22, 2002
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    0
    Just wiggling the cable doesn't seem to cause the problem to alternate. I have to unconnect the cable and reconnect it for the snowy picture to go away.
     
  4. Neil Joseph

    Neil Joseph Lead Actor

    Joined:
    Jan 16, 1998
    Messages:
    8,332
    Likes Received:
    1
    Trophy Points:
    0
    Real Name:
    Neil Joseph
    OK, this would seem to eliminate a loose internal connector on the TV then. Try cleaning the contacts on the TV's coax connector. Radio Shack or simiar place shoud have the spray can. Spray the liquid over the connector then reconnect. You say the cable is new and the ends are gold plated. Also, make sure there is enough of the internal wire on the coaxial cable sticking out of the end of the cable. It should be sticking out about 5mm past the dialectric (the white plastic insulator in the middle of the cable).

    I have had snowy pictures as a result of both a loose internal connector to the TV and having to clean the ends of the cable.
     

Share This Page