What's new

[FIXED] Audyssey MultEQ App problem with Audyssey Flat setting not working with no audio output from the speakers: A Solution (1 Viewer)


Jun 15, 2024
Real Name
Like most of you have faced this problem for almost a decade at this point or more (acc. to forum postings since when this problem was originally posted)

I have finally found a solution to it which seems to work in every case, unlike the previous fix which was just to upload the Audyssey file multiple times.

Background: so, for people who do not know, if you use Audyssey and upload the room correction EQ file to your AVR using the app, Audyssey has a few curve options such as Reference, L/R Bypass, Flat, and Off.

When we select the Audyssey Flat EQ. We would not have any audio coming out of the AVR at all and it would be dead silent, but this was not the case in the other modes. So, for me and others who had heard and liked the “Flat” Audyssey mode very much and for it to not work whenever we made any change in the app was very painful to see, other Audyssey modes were working normally but we don’t like the sound of it. This is the same issue faced by a whole lot of people for a decade at this point (based on when the first time this exact problem was posted on the internet). The best that people seem to have gotten to solving this problem was just to upload the Audyssey file multiple times but this never seems to work for me or others (but I think this was a rough fix that barely worked for some people with some old Denon receivers after they have uploaded it multiple times for it to work once and it would only work a few times until they needed to repeat this process. All of this for the “Flat” Audyssey mode to work because it would turn off the roll-off at the top end of the frequency range enhancing the natural characteristics of the speaker and making it sound much more natural and crisper and that was the reason for people to like this setting.

Why does Denon not fix it by themselves if this has been a major issue for such a long time?!:
I have a few years of basic experience working in the Embedded and Electronics, unlike the software field where you can just issue a new software update for any issue. In the Embedded field where are software works in a low level in tandem with the hardware and the physical pins and addresses cannot be changed once manufactured. When they would have released the first version of this app with new hardware. They would have never encountered this specific problem with hardware by the time they realised this problem. They would have seen that the models with issues are old/out of service spec to issue a recall and cannot be solved with a software fix.
And they don’t want to make a new app for the newer models most likely because that would create a lot of confusion for people who just want an AVR up and running and this is not meant to work with people who are not tech-savvy who just want an AVR up and running and not trying to figure out of the multiple apps by the same company and by trial and error to figure out which works for your AVR once you have spent quite a bit of dough for your AVR/Home Theatre set-up. Having multiple apps finickiness gives a sense of cheapness to the product and the company that would turn away buyers because in the same price range and cheaper, you have complete analogue receivers without any app/software fanciness and you just flip a switch and it works.

So other than hardware/financial limitations to issue a recall OR with audio companies having no resolute on-call software team OR to ensure user similarity and upkeep the at-premium value of the AVR, they have not/could not have fixed this issue.
I am not vouching for any brand and/or giving them cover for their mistakes. This is still awfully wrong from the audio company and has caused me a lot of head-banging to fix this issue by myself and leaving us consumers in the dark when asked for a fix, but this might provide some explanation for the people wondering why they cannot just fix it an update or a recall.

(Please click on the pics to enlarge it so you can see the arrows and text clearly)
Image 1: This is the home section of the app where we can see our different “Audyssey Project Curves”, The fix to get the Flat Setting to work is to use the upload button located here. Where once we click the upload to AVR button, we must select which “Audyssey Project Curves” We have to upload and then we select the desired preset we would like to upload. Doing this makes the Flat EQ Work.
Image 2: This is where most people like me used the app to upload the current configuration (Because we would have just made the edit, and we would just like to upload it using the button designated for it instead of saving, coming back to the home screen and then click). THIS DOES NOT WORK. Please follow the method shown in the above instructions (Image 1).

TLDR: Use the upload button (Send to AVR) button in the home screen of the Audyssey phone app where you can see all your different curves (image 1) just as you open the app, DO NOT use the upload button inside any of the ‘MultEQ Curve editor settings’ (Image 2) where you click on each of the different room frequency curve Audyssey presets to edit different Audyssey settings and then upload to AVR without exiting to home page of the app. Using this button inside each preset editor to upload to AVR makes the ‘Audyssey Flat’ setting NOT work.

Use the ‘Upload to AVR’ button on the app home page (Where all diff projects can be seen; img1), Click the upload to AVR button and then select the curve you want the AVR to receive. This is to be done once changes are made to the curve.
This makes all the AVR settings work as normal.


Image 2.png

Users who are viewing this thread

Sign up for our newsletter

and receive essential news, curated deals, and much more

You will only receive emails from us. We will never sell or distribute your email address to third party companies at any time.

Forum statistics

Latest member
Recent bookmarks