ETF setup with a laptop

Discussion in 'Archived Threads 2001-2004' started by Ranga, Mar 4, 2002.

  1. Ranga

    Ranga Stunt Coordinator

    Joined:
    Nov 30, 2000
    Messages:
    107
    Likes Received:
    0
    I am using a Dell Latitude CPi-A laptop with ETF 5.0 demo software and I am not sure if I have the correct connections setup to measure the frequency response.
    I used two Radio Shack Adapters (274-369), one connected to the LINE-OUT (the headphone jack) and the other to the LINE-OUT/Audio-in jack. Now the connections -
    LINE-OUT jack (Laptop)->BFD 1124's input 1
    BFD 1124 output 1 -> sub-amp line-in
    LINE-OUT/Audio-in (Laptop)-> Ratshack Meter
    LINE-OUT (Laptop) -> LINE-OUT/Audio-in (Laptop) [For sound card calibration).
    With this setup, the level check shows different values for the Microphone input (-30db) and Soundcard input (-6db). I could not get them set to the same level.
    I then tried the MIC-IN jack on the laptop connected to the Ratshack Meter. With this, both channels were set to -1db. With this setup, when I ran a test measurement, the graph showed a straight line at 100db (almost off the scale).
    Checked ETF documentation which recommends that I remove the LINE-OUT->LINE-OUT/Audio-in connection on the laptop. A level check indicated -39db on the Microphone input channel and -34db on the Soundcard input channel. The 2 test measurements give me these graphs -
    [​IMG]
    This doesn't look anything like what I measured manually -
    [​IMG]
    I did read BruceD's post that the connection to the laptop should be to the line-in and NOT the Mic-in. But I could not get the levels set to the same db on both channels.
    Would the line-in be equivalent to the Audio-in on my laptop (the jack is described as a record/playback jack?
    Any other suggestions?
    Ranga
     
  2. Pete Mazz

    Pete Mazz Supporting Actor

    Joined:
    May 17, 2000
    Messages:
    761
    Likes Received:
    0
    Did you go thru the mixer setup as outlined in the getting started section of the help file? Basically, you have to set the line out level and the record level. The record level (line in) will let you adjust the signal. Both signal levels in ETF have to be -10 to 0 dB.

    Pete
     
  3. Rick Radford

    Rick Radford Supporting Actor

    Joined:
    May 12, 2001
    Messages:
    642
    Likes Received:
    0
    Ranga,

    Is your laptop's soundcard full duplex?

    If not, I don't believe you can use the internal soundcard in this mode. You have to d/l and burn a cd of the MLS tones and take your measurements in half duplex mode.

    The adapters I used were the 274-883 (gold plated) ones which I think are equivalent to your -369 model.

    Even if your laptop is full duplex, I don't know that my pc's sound card (SC) will relate to yours. My SC line out (for my pc speakers) is connected to one RCA-1/8 stereo adapter. My SC line-in (not mic-in) uses another RCA-1/8 adapter. The left channels of both adapters are tied together.

    The right channel of the SC line-out goes to my receivers CD input (right channel). The right input of the SC line-in is connected to the Ratshack meter.

    The mixer output needs to have all muted except the wave out. The mixer record input needs to have all muted except the line input. You may have to adjust the record line input levels to get the input level (Channel 2) into the green, as Pete said.

    Your RS spl meter and volume control of your receiver or pre/pro work with each other in establishing the correct level for Channel 1 (RS mic input). As a point of reference, I set the Rs meter to the 80 or 90 dB range and the Master Volume of the receiver was set to 5 to 10 below ref level.

    HTH.
     
  4. Ranga

    Ranga Stunt Coordinator

    Joined:
    Nov 30, 2000
    Messages:
    107
    Likes Received:
    0
    I followed the instructions in the ETF help section. My sound card is full duplex.

    My levels with the Audio-IN jack never matched. They match only with the MIC-IN.

    In step 4 (Level check), ETF recommends that I disconnect the line inputs from the output and repeat the level check.

    When not disconnected, I got -1db on both channels. After they were disconnected, the readings were -34db and -39db, which I thought were in the acceptable range.

    In the troubleshooting section, I looked at the linear frequency response graph and my graph looks very similar. I may have reversed the connections.

    I will try again this evening.

    Ranga
     
  5. Ranga

    Ranga Stunt Coordinator

    Joined:
    Nov 30, 2000
    Messages:
    107
    Likes Received:
    0
    Well,
    I am back where I started. I have the levels matched with the MIC-IN and LINE-OUT jacks connected to the RS meter and Sub respectively.
    When I run the test, I get a straight line close to 100db -
    [​IMG]
    As I mentioned before, when I use the LINE-OUT/AUDIO-IN jack, there is a difference of almost 30db between the microphone input channel and soundcard input channel. According to the ETF documentation, it seems that I could use either MIC-IN or LINE-IN. Is this right?
    Ranga
     
  6. Rick Radford

    Rick Radford Supporting Actor

    Joined:
    May 12, 2001
    Messages:
    642
    Likes Received:
    0
    Ranga,

    A few excerpts from the help file (just to reiterate). If these don't help, you probably should call or email the author of ETF for more help since support is available free even for the demo version.

    >If you are using a laptop, use the battery power to eliminate the power supply noise from interfering with measurements<

    >The "3 D effects" or other special effects may be enabled on your sound card. These options should be disabled before any measurements with ETF are attempted. Click on the multimedia icon in the Windows Control Panel to gain access to these settings.<

    >This mixer has a play window and a record window. <

    Play Window

    >The only signal that ETF should play through the system under test is the wave signal. Other signals being played through the sound card will interfere with the test signal playing and affect results. All sources except Wave and Master Volume / Volume Control should be muted turned off or volume control reduced to zero.<

    Record Window

    >In this setting the mixer will only record through the line level inputs. The will prevent other sources from interfering with the recording (being mixed in with the recording). All undesired sources such as CD Audio, MIDI, and Microphone should be muted, turned off or volume control reduced to zero. <

    That should get you to level 4 (level check).

    I don't know about line in vs mic in.

    Gotta run for now...
     
  7. Andrew Low

    Andrew Low Extra

    Joined:
    Jul 27, 1999
    Messages:
    23
    Likes Received:
    0
    The RS SPL meter has a built in 'amplifier' for the signal on the RCA output jack. This is the reason that you should be using the line-in on your sound card.

    I found that the amplified signal was pretty 'hot' compared to what my soundcard was expecting. So, when measuring using the SPL meter I had to turn the 'range' up on the meter about one setting.

    Thus, in normal use a 75dB signal I'd have the meter set for the '70' range and I'd have the needle (analog meter here) moving nicely. If I fed this signal into the line-in, it would be too high, even after turning the line-in input down a little. Plus it was impossible to balance the sound card loop back line..

    By turning the meter up to '80' I got a usable balance between the loop back and the speaker/meter signal loop. My estimation is that this simply turns down the 'gain' on the internal pre-amplifier in the RS SPL meter (I could be wrong of course).

    I haven't compared my ETF readings with manual SPL readings (I keep meaning to do this). However, from past manual measurements it doesn't seem to be wildly off (based on memory).

    Please note: the RS SPL meter is only useful for low frequency readings, the microphone element is poorly mounted for higher (1KHz->) readings.

    Roo
     
  8. Rick Radford

    Rick Radford Supporting Actor

    Joined:
    May 12, 2001
    Messages:
    642
    Likes Received:
    0
    >the RS SPL meter is only useful for low frequency readings, the microphone element is poorly mounted for higher (1KHz->) readings.<

    From other comparisons I've seen posted, the RS meter appears to begin diverging around the 8k freq level. I believe the RS correction files show this as well.

    FWIW.
     
  9. Ranga

    Ranga Stunt Coordinator

    Joined:
    Nov 30, 2000
    Messages:
    107
    Likes Received:
    0
    Andrew
    You may have something here. I was under the assumption that the RS SPL meter can be turned OFF since only the mic is being used. Is this not correct?
    My problem with using the LINE-In is I have a -30db difference between the channels. Could this be because I have turned the RS Meter OFF?
    Rick
    Answers to your query -
     
  10. Rick Radford

    Rick Radford Supporting Actor

    Joined:
    May 12, 2001
    Messages:
    642
    Likes Received:
    0
    Ranga,
    Let's try with the RS meter on. I think that's your problem. I had a similar problem on my setup.. and couldn't figure it out.. and discovered I'd left the RS meter OFF. sheesh. [​IMG]
     
  11. brucek

    brucek Second Unit

    Joined:
    Dec 29, 1998
    Messages:
    335
    Likes Received:
    0
    I've been following this thread trying to figure out what was wrong.

    It never even crossed my mind that you had the meter shut off. That is definitely your problem - good call Andrew.

    You can easily see this once you've turned it on and are doing a level loopback level check. If you rotate from 70dB scale to 80dB scale, you'll see your level jump up accordingly in ETF, just as it does on the SPL meter itself. I found 80dB scale the best for the least chance of feedback.

    brucek
     
  12. Ranga

    Ranga Stunt Coordinator

    Joined:
    Nov 30, 2000
    Messages:
    107
    Likes Received:
    0
    It works!!

    I am posting my results in the Speaker & Sub forum. Need your input for setting the BFD filters.

    Ranga
     

Share This Page