Energy EXL15's and Energy C-center question?

Discussion in 'Archived Threads 2001-2004' started by scott_tinari, Dec 20, 2001.

  1. scott_tinari

    scott_tinari Stunt Coordinator

    Joined:
    Feb 10, 2001
    Messages:
    121
    Likes Received:
    0
    I just picked up the Energy EXL15's for the fronts and the Energy C-center, Now I have ahd them for about a week, I think they are broken in, When I get them they sounded great not, its like I have to play at high volume to get anything out of them, has this happend to anyone?, I have Energy Take 5's for the rear is this ok with my Fronts and center?
     
  2. KeithH

    KeithH Lead Actor

    Joined:
    Mar 28, 2000
    Messages:
    9,413
    Likes Received:
    0
    Scott, that's odd. Check your wiring and your receiver. I doubt something went wrong with all three new speakers at once. Try connecting the Take 5s as your fronts and see if the sound improves. Use the same wires as you are using for the e:XL 15s, then try the wires you have been using for the Take 5s all along. I've been using e:XL 16s as my mains and recently replaced the e:XL-C with the e:XL-C2 and have never had problems getting sound from these speakers.
     
  3. Marc H

    Marc H Second Unit

    Joined:
    Aug 22, 2001
    Messages:
    497
    Likes Received:
    0
    Hi Scott,

    How do you find the treble match between the e:XLC and the e:XL15? I always found them different sounding.
     
  4. VicQ

    VicQ Stunt Coordinator

    Joined:
    Aug 19, 2001
    Messages:
    87
    Likes Received:
    0
    Scott,
    I have two different setups using the 15's and the C1, one at my parent's place, and the other at my girlfriend's. I have tonal consistency across the front when I have these speakers paired up so there's no problem.
    -Vic [​IMG]
     
  5. Paul_Dunlop

    Paul_Dunlop Second Unit

    Joined:
    Nov 28, 2001
    Messages:
    318
    Likes Received:
    0
    Hi
    First off i have the following setup
    Center - EXL-C
    Mains - EXL-16
    Surround - EXL-15
    I ran the center with EXL-15's for about 6 months and thought it sounded great. My only issue was the cheap JBL surrounds I was using.
    I bought the XL-16's last week and put them up front - not only does it sound considerably better, it totally proves the Timbre matching issue.
    I ran a helicopter scene in the movie Swordfish, which circles all the speakers - UNBELIEVABLE - what a totally different experience.
    I would suggest you pick up another set of the XL-15's at minimum, or go with the XL-16's if you have the room.
    One item to check on your reciever is the setting for the surrounds - a lot of people crank up the volume on the surrounds because they can't hear much from them. If this is the case, that might be why your new fronts and center sound quiet. Set all your speakers back to '0' and see if this solves the issue (before you calibrate for the new speakers)
    Take it easy
    Paul
     
  6. Haywood

    Haywood Stunt Coordinator

    Joined:
    Aug 12, 2000
    Messages:
    81
    Likes Received:
    0
    Scott what kind of receiver are you using? It sound's like the xl's are not getting enough power. It takes a little more juice to push those instead of the Take 5's.
    Later Haywood [​IMG]
     

Share This Page