EAD Powermaster 1000 channel dead

Discussion in 'Archived Threads 2001-2004' started by Christopher Lyn, Jan 17, 2003.

  1. Christopher Lyn

    Christopher Lyn Stunt Coordinator

    Joined:
    Jan 1, 2002
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    0
    I just bought a used EAD Powermaster from a guy in Calgary. However, the channel closest to the power cord on the amp is "dead." No sound comes through.

    Are there any authorized dealers of EAD in Canada...preferrably Ontario, that anyone knows?
     
  2. Christopher Lyn

    Christopher Lyn Stunt Coordinator

    Joined:
    Jan 1, 2002
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    0
    Well here is an update. With lots of trepidation and the advice of my EAD dealer, I opened up the case. I bought the amp from another person, so I did not have a warranty anyway.
    I used an Ohm meter to test the fuses and wires....low and behold, the wire from the channel that was "dead" (rear left surround) was loose and unconnected to where it should have been (labeled speaker out on the circuit board).
    I plugged the wire back on and the channel was working again. When I closed the case and connected my inputs and speakers the front right speaker was "dead." I opened up the amp again and could find no more loose wires or blown fuses...so I switched the left front speaker with the right front speaker (wires and input) on the amp. No problems, all channels worked fine. I switched the speakers and inputs on the amp, back to where they were originally, and everything is OK...for now.
    Still don't understand why the right front went temporarily "dead." I checke the connections and everything was solid.
    I should have prefaced this entire adventure with the fact that, when the UPS guy delivered my amp, my father said he saw him rolling the amp, on it's side, up the driveway to my front door. I blame this whole event on the UPS man. Don't they have dollys or something to help them with heavy parcels"?
     
  3. Dave Simpson

    Dave Simpson Second Unit

    Joined:
    Sep 18, 1999
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    0
    A curse on those UPS guys, Chris! Glad to hear everything appears to be working out.
    All's well here with the 1205, though I've yet to really put it through its paces (no time, yet). I'll contact you through e-mail with my personal info. Cheers!

    DS.
     

Share This Page