What's new

Denon Home 250 Speaker - Popping and Clicking sounds (1 Viewer)

uwired

Auditioning
Joined
Feb 7, 2021
Messages
2
Real Name
uwired
Hi guys :), first time poster here so hopefully this is the right place to post this thread.

I recently bought a (open box, unused) wireless Denon Home 250 speaker. And it's the first time I've had a dedicated wireless music speaker in the home.

I'm having (what I think is an issue) where when playing music or video through AirPlay or Bluetooth I hear a 'track skipping' sounds and a very audible 'pop' sound a second or so into playback. The louder setting the speaker is at, the more audible the popping sound.

I have used my iPhone 11 and my iPad Pro, and the same happens with both.

The same happens with video playback on Netflix or YouTube, etc. (see below videos).

Music Playback (AirPlay)

Video Playback

I don't have any such issues when playing directly through an AUX cable.

My question is: Is this 'normal'? Or should I not be having this issue at all?

I have a much smaller Denon DSB 250 speaker and have none of these issues.

Is this a fault and should I return it? Hoping someone can shed some light. :)
 

Peter Apruzzese

Senior HTF Member
Joined
Dec 20, 1999
Messages
4,299
Real Name
Peter Apruzzese
I have a couple of Denon HEOS speakers and have the same issue trying to stream to them via Bluetooth from either my iPhone or iPad. Streaming from other devices via Bluetooth works fine without the stutter like the iOS devices do. I did a deep Google search a while back and there are other users with that same issue. Denon told me to just re-install the Heos app and update the iOS devices to the latest version, but that didn't fix it. I only use them via WiFi now.
 

uwired

Auditioning
Joined
Feb 7, 2021
Messages
2
Real Name
uwired
I have a couple of Denon HEOS speakers and have the same issue trying to stream to them via Bluetooth from either my iPhone or iPad. Streaming from other devices via Bluetooth works fine without the stutter like the iOS devices do. I did a deep Google search a while back and there are other users with that same issue. Denon told me to just re-install the Heos app and update the iOS devices to the latest version, but that didn't fix it. I only use them via WiFi now.
Thank you for your response, Peter 😊

I get the same issue when playing though WiFi (I’m assuming you mean “AirPlay”?)

I was going to return this and re-purchase brand-new for £130 more via Amazon. But I’m in two minds, if I get the same issue with the second unit then it’s a waste of time and funds 😂

I raised this with Denon and their response came through yesterday:

“Dear Customer,
Thank you for your patience.
In response to your query, please refer to the dealer where the unit was purchased from, for a service request to be processed. The unit may have a potential hardware fault, in which case it will require further inspection.
Should you require further assistance, please do not hesitate to contact us.
Best regards,
Sound United Support”

What do you think I should do? 😂
 

Peter Apruzzese

Senior HTF Member
Joined
Dec 20, 1999
Messages
4,299
Real Name
Peter Apruzzese
I don’t have any issues with them on wifi. The Heos units don’t use Airplay, the iOS devices are just using apps to control them but the music streams direct from wifi.
 

Users who are viewing this thread

Forum Sponsors

Forum statistics

Threads
346,870
Messages
4,793,454
Members
141,921
Latest member
Artscience100
Top