Denon 3803 Video Problem

Discussion in 'AV Receivers' started by pastor stacruz, Dec 28, 2003.

  1. pastor stacruz

    pastor stacruz Auditioning

    Dec 26, 2003
    Likes Received:
    I bought a Denon 3803/1083, a Panasonic F61A & a Gateway 42" HDTV and a set of Paradigm speakers just before xmas and for over a week, we enjoyed listening to CDs and and watching TV & rented DVDs with them.
    Two days ago, we lost the video1 (Denon's "DVD" designation) connection so I moved the component cables over to Denon's video2 ("DBS") and this morning we lost that connection too. Just last night, I watch a DVD without any problem and this morning, with the same DVD and without any AVR setup at all, only audio could be heard now but no video at all. So, in order for my wife to watch the DVD, I hooked-up the component cable from the DVD player directly to the component2 input of the plasma, leaving the optical link to AVR in place, and she is out there now watching the movie.
    What do you think is the problem here? The connection is as follows:
    Panasonic DVD/CD to Danon 3803 AVR
    video - component cables to video2 ("DBS")
    Audio - optical cable to opt1
    Danon 3803 to Plasma -
    Danon component OUT to plasma component1 IN
    BTW, I can no longer do on-screen-display/setup in "DBS or DVD function.
    Any help would be highly appreciated.
  2. BrianWoerndle

    BrianWoerndle Supporting Actor

    Feb 19, 2002
    Likes Received:
    First thing to try would be a processor reset. That solves a lot of problems. If that doesn't work you may want to take it back and have it looked at.

Share This Page