What's new

Component video in/out broken? (1 Viewer)

Geoff::L

Agent
Joined
Dec 11, 2003
Messages
29
I just got my receiver (HK 230) and I tried connecting the component cable from my DVD player to the receiver and then another set of component cable from the receiver to the TV. When I watched a movie it had a greenish tint to it. It seemed like the reds were not coming through.
I double-checked it to make sure I had the right cables going to the right color inputs also.

I connected the component cable directly from the DVD player to the TV and the picture was fine. I tried both component cables and they were both good.

Does this mean that there might be something wrong with the receiver or do I have to set something up with the receiver?
 

Cees Alons

Moderator
Senior HTF Member
Joined
Jul 31, 1997
Messages
19,734
Real Name
Cees Alons
Geoff,

It should work. How do pictures of other sources (going through your receiver) look?

If you don't have other sources, is there a need indeed to loop your video image through the receiver?


Cees
 

Geoff::L

Agent
Joined
Dec 11, 2003
Messages
29
It was the component cable I bought from Target that was defective. It seemed to work at first when connected directly to the TV but then after awhile the screen would go a yellowish green again and then back to normal.

I replaced it with an RCA brand component cable from Home Depot and everything works fine now.
 

Users who are viewing this thread

Forum Sponsors

Forum statistics

Threads
346,132
Messages
4,767,313
Members
141,681
Latest member
Kossian
Top