Component video in/out broken?

Discussion in 'AV Receivers' started by Geoff::L, Jun 2, 2004.

  1. Geoff::L

    Geoff::L Agent

    Joined:
    Dec 11, 2003
    Messages:
    29
    Likes Received:
    0
    I just got my receiver (HK 230) and I tried connecting the component cable from my DVD player to the receiver and then another set of component cable from the receiver to the TV. When I watched a movie it had a greenish tint to it. It seemed like the reds were not coming through.
    I double-checked it to make sure I had the right cables going to the right color inputs also.

    I connected the component cable directly from the DVD player to the TV and the picture was fine. I tried both component cables and they were both good.

    Does this mean that there might be something wrong with the receiver or do I have to set something up with the receiver?
     
  2. Cees Alons

    Cees Alons Moderator
    Moderator

    Joined:
    Jul 31, 1997
    Messages:
    19,345
    Likes Received:
    291
    Real Name:
    Cees Alons
    Geoff,

    It should work. How do pictures of other sources (going through your receiver) look?

    If you don't have other sources, is there a need indeed to loop your video image through the receiver?


    Cees
     
  3. Geoff::L

    Geoff::L Agent

    Joined:
    Dec 11, 2003
    Messages:
    29
    Likes Received:
    0
    It was the component cable I bought from Target that was defective. It seemed to work at first when connected directly to the TV but then after awhile the screen would go a yellowish green again and then back to normal.

    I replaced it with an RCA brand component cable from Home Depot and everything works fine now.
     

Share This Page