What's new

Color Washes Out into Browns with New Blu Ray Player - HELP! (1 Viewer)

WilliamG

Supporting Actor
Joined
Aug 6, 2001
Messages
513
I've owned a Toshiba 50H81 50" widescreen and a Panasonic RP56 DVD player for several years now and everything was great. I just got a Samsung BD-P1500 Blu Ray player for Christmas, and thought we'd enjoy some wonderful movies for the day - but a problem came up that I desperately need help with.

After a disc loads, I immediately notice a color 'loss' ... a difference that wasn't there with my older player. Example: the movie "Iron Man" - his suit is a pug-ugly brown color where the vibrant red should be. The yellow is a yellow-green. I've tried going in and changing the settings on the Toshiba, but to no avail.

I put in "The Dark Knight", and everything seems a brown/greenish color ... yuck!

Regular TV viewing is not affected; the colors are great.

If anyone still owns this set and is experiencing the same problems, please tell me how you fixed it.

(I haven't been around on the forum in a while; life happens, you know ... but I have returned and am frantic to find an answer!)

Thank you so much in advance!
 

Patrick Sun

Senior HTF Member
Joined
Jun 30, 1999
Messages
39,625
If you're using component video (red, green, blue video connections), you probably mixed up 2 of the color connections).
 

WilliamG

Supporting Actor
Joined
Aug 6, 2001
Messages
513
Patrick-

THANKS!
It turns out that, in fact, I hadn't switched them, but that I hadn't pushed one of the plugs all the way in.
I KNEW there was a reason I loved this site ... and how much I've missed it.

I thank you, my wife thanks you, my dog tha-- well- maybe not my dog ...:laugh:

Happy New Year!

William
 

Users who are viewing this thread

Forum Sponsors

Forum statistics

Threads
355,771
Messages
5,091,063
Members
143,927
Latest member
Mindy
Recent bookmarks
0
Top