Can't use VMR9 at all without tearing in ZP

Discussion in 'Computers' started by Greg Palma, Jan 7, 2006.

  1. Greg Palma

    Greg Palma Auditioning

    Joined:
    Aug 20, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    The graphics card is a 6600GT, with Forceware 82.12 drivers. I can use VMR7 without any tearing, but if I use VMR9 (renderless of otherwise) I start to see this artifact, even with fullscreen exclusive enabled in filter control (it might even get worse with this option).

    I just wanted to see if anyone here had any ideas...help?[​IMG]
     
  2. Scott L

    Scott L Producer

    Joined:
    Feb 29, 2000
    Messages:
    4,457
    Likes Received:
    1
    Trophy Points:
    0
    Are you using FFDSHOW or the nvdvd processing options?
     
  3. Greg Palma

    Greg Palma Auditioning

    Joined:
    Aug 20, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    I'm using FFdshow, but even without FFdshow, I still get tearing. FFdshow doesn't seem to be the problem, because with or without it, I still get tearing in VMR9. I have no idea what I should be doing differently. Can you suggest other video drivers I should use? Would Reclock make a difference?


    Thanks,
    Greg
     
  4. Scott L

    Scott L Producer

    Joined:
    Feb 29, 2000
    Messages:
    4,457
    Likes Received:
    1
    Trophy Points:
    0
    IIRC, when I upgraded from a p2.4b to a p2.8 @ 3.4 I didn't have to worry about tearing anymore. Is your CPU pretty fast?

    But then again if you're not using ffdshow or any other post-processing options, your 6600GT should be picking up the slack. When playing a DVD, double click the nvdvd systray icon and make sure you can choose VMR9 pixel adaptive de-interlacing in the options. If you can PureVideo is enabled, if not, there's something in the chain preventing its use.

    Also see how WMP10 plays your DVDs. ANd making sure you have the latest version of DirectX never hurts.
     
  5. Greg Palma

    Greg Palma Auditioning

    Joined:
    Aug 20, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    I forgot to mention that I'm actually using Descaler5. I don't think I have any options like that, but I'm not sure how to access them if I do.

    Also, WMP 10 says "DVD-Video playback graph has not been built yet" when I try to play a DVD.

    I ran Dxdiag and I have DirectX 9.0c (4.09.0000.0904).

    What does this indicate?
     
  6. Scott L

    Scott L Producer

    Joined:
    Feb 29, 2000
    Messages:
    4,457
    Likes Received:
    1
    Trophy Points:
    0
    I would suggest downloading the latest purevideo decoder and re-installing it. It should work flawlessly with WMP10.

    If you have some universal control settings for DScaler or ffdshow turn them off too.

    You can also try downloading the latest ZP Pro trial and see how nvdvd plays on that.
     
  7. Greg Palma

    Greg Palma Auditioning

    Joined:
    Aug 20, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    I finally got around to installing Purevideo, and selected it in ZP, but I still get the same issues with VMR9, with or without ffdshow.

    Is there anything else I can do, other than getting another video card?
     
  8. Scott L

    Scott L Producer

    Joined:
    Feb 29, 2000
    Messages:
    4,457
    Likes Received:
    1
    Trophy Points:
    0
    Look at my 2nd post and see if PureVideo is actually working.

    Click the tray icon that pops up and see what de-interlacing options are available. If you don't see some fancy ones like Pixel Adaptive and a couple of others then it's not working.

    Also wouldn't hurt to check out the HTPC section at AVS. Chances are there are many who've dealt with the same problem as you and fixed it.
     
  9. Greg Palma

    Greg Palma Auditioning

    Joined:
    Aug 20, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    Hi Scott,

    Sorry that I'm being a moron about this, but I do appreciate your help.

    For one thing, I don't get a tray icon for Purevideo, I can only open a dialog box when I select it in ZP. No VMR9 pixel adaptive in the de-interlacing options, so I guess it's not working. You said I might have some universal control settings that I need to turn off, but I'm not sure specifically what you mean. Should I uninstall Dscaler?

    Again, thanks for your time. I got nowhere at AVS so far.
     
  10. Greg Palma

    Greg Palma Auditioning

    Joined:
    Aug 20, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    Okay, can anyone else give me a clue then?
     
  11. Max Leung

    Max Leung Producer

    Joined:
    Sep 6, 2000
    Messages:
    4,611
    Likes Received:
    0
    Trophy Points:
    0
    Is Zoomplayer configured to use the NVIDIA decoders for DVD playback? It's a very complex program to configure...
     
  12. Greg Palma

    Greg Palma Auditioning

    Joined:
    Aug 20, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    Max,

    ZP gives me the option to use NVDVD when setting up, but it's control panel only gives me the regular options for de-interlacing (ie. "smart, best available" for defaults). I don't have the VMR9 pixel adaptive option available. Does this depend on the version of NVDVD I'm using?
     
  13. Max Leung

    Max Leung Producer

    Joined:
    Sep 6, 2000
    Messages:
    4,611
    Likes Received:
    0
    Trophy Points:
    0
    You won't get the pixel adaptive option unless you are actively playing a video while configuring it. As far as I know, all versions of Purevideo (since last year) have pixel adaptive as an option.

    If you are still seeing tearing, I would suggest making a back up of your OS partition (with Norton Ghost or Acronis TrueImage) and reinstall windows.

    With that said, are you using any unusual hardware in your system? TV tuners? The more cards you have in your PC, the higher the chance that they will introduce problems with video playback, which is extremely sensitive timing-wise.
     

Share This Page