1. Sign-up to become a member, and most of the ads you see will disappear. It only takes 30 seconds to sign up, so join the discussion today!
    Dismiss Notice

Can't seem to get 4K HD from a PS4 Pro on a Samsung Q7 TV through Denon receiver?

Discussion in 'Displays' started by Phil Carter, May 2, 2018.

  1. Message #1 of 1 May 2, 2018
    Last edited: May 2, 2018
    Phil Carter

    Phil Carter Second Unit

    Joined:
    Jan 9, 2003
    Messages:
    337
    Likes Received:
    0
    Trophy Points:
    110
    Location:
    Austin, TX
    Real Name:
    Phil
    Good day folks!

    So I recently bought a Playstation 4 Pro so I could experience 4K gaming on my Samsung 75" 4K television. I currently have several pieces of equipment running into the various HDMI input ports on my Denon receiver, with a single output cable from the Denon's HDMI Out (ARC) port that runs to HDMI input 2 (ARC) on my Samsung's OneConnect box. The PS3 and Steam Link obviously don't output at 4K, but my Panasonic DMP-UB900 4K Blu-ray player does, and I've had no trouble viewing 4K Blu-rays on it, or viewing 4K content from the Panny's Netflix application.

    So when I bought the Playstation 4 Pro, I figured it would be simple: output cable from PS4 Pro to a free input port on the receiver and I'd be done. Only it hasn't quite worked out that way.

    See, when I hooked the PS4 up and ran through the standard setup, I got a complaint notification onscreen: "Your TV might support a higher quiality color format and 4K HDR if you change its settings. Check your TV's settings."

    I did some digging on Google and it was suggested that the cabling might be an issue. At which point I found that the cabling I'd originally used for output from the Denon to the TV was not HDCP 2.2 compliant (they were high speed, but supported 10 GB bandwidth only). The one included with the PS4 itself is supposedly HDCP 2.2 compliant.

    Not being certain about the other cables, I tried running the PS4 Pro's output cable directly to the HDMI input 1 on the TV. When I did, the error message in the video output section of the PS4 Pro went away, and as far as I could see, I was getting full 4K HDR with Shadow of the Colossus. But not full surround sound, because it wasn't running through the receiver anymore and the ARC from the TV back to the receiver just comes out as stereo.

    So I bought three new cables from Monoprice (these cables here). They arrived yesterday and I replaced three cables in the setup with these new ones:

    -- Denon HDMI output (ARC) to HDMI port 2 (input) on Samsung OneConnect box
    -- 4K Blu-ray player output to HDMI input port on Denon receiver
    -- PS4 Pro output to HDMI input port on Denon receiver

    Switched on the PS4. Now getting full surround sound in games, but as for video.........it reverted to the previous complaint. "Your TV might support a higher quality color format and 4K HDR if you change its settings". Also, if I tried playing Shadow of the Colossus again, I got another warning: "This application supports 4K HDR (high dynamic range) but it will be displayed in 2K HDR because of your TV's settings. If your TV supports 4K HDR, try changing your TV's settings."

    So I did some more Googling and found multiple suggestions, none of which have worked yet.

    On the PS4, I've tried:
    -- Settings / Sound and Screen / Video Output Settings: changing the "Resolution" option from Automatic to "2160P - YUV420" ("2160P - RGB" is grayed out and says "not supported"). No change.
    -- Changing the "RGB Range" option to "Full". No change.
    -- Going to Settings and disabling HDCP entirely (since I will only be using this for games). No change.

    On the TV itself, I've tried:
    -- Settings / General / External Device Manager / Anynet+ (HDMI-CEC): tried disabling this. No change.
    -- Settings / General / External Device Manager / HDMI UHD Color: HDMI 1 through 4 are already enabled. Tried disabling it for HDMI2 (the port that's in use), and the screen went black briefly as it negotiated; I then reenabled the option, the screen went black briefly as it negotiated, but when I closed out of Settings and went back to check video output on the PS4 it still showed the same error.
    -- Settings / Picture / Expert Settings: tried setting "HDR+ Mode" to off. No change in error.

    On the Denon receiver, I've tried:
    -- Going to the Video menu and setting "4K Signal Mode" to "Enhanced". Doing this allows the full range of output options in the PS4's video output menu.........but it also causes the signal to be lost every few seconds (signal dropout with the screen being off more than it is on). That's not a workable solution.

    According to Samsung all input ports on the Samsung OneConnect box are HDCP 2.2 compliant. According to Denon all ports on the receiver are HDCP 2.2 compliant. According to Monoprice, all 3 of the HDMI cables I'm using for connections are HDCP 2.2 compliant and support 18 GB bandwidth.

    So.......any suggestions? I would really like to get proper 4K video from the PS4 and still get surround sound. All equipment info is in the signature below. Beginning to look to me like this is a Denon issue.

    Thanks in advance for any further ideas!

    [[EDIT later that day: Just out of curiosity I tried swapping out the brand new Monoprice "18 GB premium certified" cable I was using for HDMI Out from the receiver to the TV, replacing it with the HDMI cable provided with the PS4 Pro. I left the two new Monoprice cables in the chain from PS4 output to Denon input, and 4K Blu-ray player output to Denon input. As soon as I made this cable switch, I could change the Denon's Video / 4K Signal Mode to "Enhanced", WITHOUT video dropouts......and the PS4 then immediately automatically switched to 4K UHD, RGB output, with no more complaints. Shadow of the Colossus plays in 4K HDR with surround.

    So it looks like I had two issues: at least one dodgy cable AND the "4K Signal Format" needed to be set to "Enhanced" in the receiver's Video menu. Leaving this up here just in case it can help somebody else out.]]
     

Share This Page