What's new

Bought a new TV, no more HDMI audio from PC thru receiver (1 Viewer)

Helgaiden

Auditioning
Joined
Aug 26, 2021
Messages
2
Real Name
Chris
So I have my TV and PC connected to my Denon receiver (which I got in 2012). Its a 1080p receiver which I'm sure will matter. For the longest time, my Samsung 1080p 55" worked well with the PC thru the receiver. Audio over HDMI thru the receiver from the graphics card worked as it should, recognized as it should. That TV stopped working recently and I upgraded to a TCL 65" 4k mini-LED TV that I really like. Its the only part of the setup that changed, otherwise its connected to the receiver identically. However, now the PC can't send audio to the receiver at all. The PC thinks there is only a DVI display connected with no audio capabilities. I did some poking around online and found that this can be related to the EDID of the TV not passing through the receiver to the PC properly, but I'm not sure. I tried via HDMI and even via DP to HDMI adapter, no change. DDU'd the driver and reinstalled, no change. Rolled back to an old driver that supposedly didn't have an audio bug I saw that could cause this, no luck. The only thing I can think of is 4k TV through 1080p receiver is a problem? I don't know.

Any advice? Would really like to have this working again. Thanks.

Image below to show you whats going on:


v3okrWq.png
 

Helgaiden

Auditioning
Joined
Aug 26, 2021
Messages
2
Real Name
Chris
Solution found. Got a suggestion to plug in a spare monitor, which I did. Audio worked correctly. Plugged the PC back to the receiver, same problem. Looked around the TV and decided what the heck, Ill unplug the HDMI that goes from the TV to the receiver then plug it back in. Voila, fixed. I feel dumb now lol.
 

Users who are viewing this thread

Forum Sponsors

Forum statistics

Threads
348,762
Messages
4,856,041
Members
142,375
Latest member
Scoundrel
Recent bookmarks
0
Top