Blotchy Screen on older RPTV

Discussion in 'Displays' started by Dave Corbitt, Apr 9, 2003.

  1. Dave Corbitt

    Dave Corbitt Extra

    Joined:
    Feb 23, 2000
    Messages:
    20
    Likes Received:
    0
    Location:
    Whiting, NJ
    Real Name:
    Dave Corbitt
    Maybe someone can give me some advice. I have an older Toshiba RPTV with the usual Fresnel / lenticular combo screen. The screen has developed blotchiness which can be annoying during screening of anything. I took the screen off the set and opened the sandwiched Fresnel and lenticular sheets to see what I could see. The Fresnel lens appears to be the source of the problem. At first I thought it might be mildew but a closer look at the Fresnel doesn't quite look like that. I tried wiping the fresnel ridges with a soft damp cloth and the blotches do not diminish. Any clues as to how I can resolve this without replacing the Fresnel lens?

    Thanks
    Dave
     
  2. Dave Corbitt

    Dave Corbitt Extra

    Joined:
    Feb 23, 2000
    Messages:
    20
    Likes Received:
    0
    Location:
    Whiting, NJ
    Real Name:
    Dave Corbitt
    It's been several years since I posted that. I got rid of the RPTV a couple of years ago but not until I replaced the Fresnel element. It was etched somehow and that caused the blotchiness. I suspect it was mildew from the basement room I had the home theater gear in. Replacing the Fresnel fixed the problem. I then bought a front projection HD Yamaha unit and gave the RPTV away to a friend who still uses it. It's now 12 years old and still working as well as can be expected for something of that design.
     

Share This Page