Big Issue with my Fairly New LCD - All Red

Discussion in 'Playback Devices' started by Joe_Papeo, Oct 3, 2006.

  1. Joe_Papeo

    Joe_Papeo Stunt Coordinator

    Joined:
    Jan 1, 2001
    Messages:
    65
    Likes Received:
    0
    Back in May I purchased a 26" LG 26LX1D LCD for my bedroom. The reviews for this model were all very good. Even at home the picture quality was amazing for both HD and SD TV.

    For the past one month I have been having 2 issues.

    The major issue is that my screen turns red. Sometimes it is normal with red outlines on the people's body, or on the clouds or other objects.

    Other times it is TOTALLY Red. You can still make out images and even watch the TV, but there is nothing but red colors and shades in the picture.

    Calling LG they told me it was probably my cable box or wires so I changed both. Same problem.

    Now they are saying it could be the feed from the cable company...I call bull. No way I am having the cable company come out to run a new main wire if I dont have to.

    The second problem is that sometimes I turn on the TV and there is no picture, only sound. I turn it off and on again and its fine.


    I am so disappointed right now. I called the service company and they are coming out to look at it on Thursday but when I spoke to the Tech he said he has never heard of this before nor does he ever see these TVs come in for service. Doesnt sound promising.

    Any idea on what this could be?
     
  2. Mike Romo

    Mike Romo Stunt Coordinator

    Joined:
    Feb 14, 2000
    Messages:
    64
    Likes Received:
    0
    Wow, that's a true bummer...I hope they replace it for you--is it still under warranty?
     
  3. homthtr

    homthtr Supporting Actor

    Joined:
    Sep 5, 2006
    Messages:
    519
    Likes Received:
    0
    Yes Given your description of the problem it's the TV.

    Good old Zenith... no wonder they came up with the new LG Division!
     
  4. videobruce

    videobruce Stunt Coordinator

    Joined:
    Sep 23, 2003
    Messages:
    143
    Likes Received:
    0
    Goldstar bought Zenith years ago. Love it when your told "never heard of that before". Yea, it must be cable. Their blue and green signal is missing. [​IMG]
    Have you tried the sets internal tuner bypassing your STB?

    "Lifes' Good" my a**. [​IMG]
     

Share This Page