B&K Reference 20 won't power on?

Discussion in 'AV Receivers' started by Rob||Kur||, Jul 3, 2003.

  1. Rob||Kur||

    Rob||Kur|| Stunt Coordinator

    Joined:
    May 9, 2003
    Messages:
    112
    Likes Received:
    0
    I just received a Ref 20 second-hand from a very nice guy, but the thing won't power on. I don't understand. It doesn't look like it was damaged in shipping at all, but he says he will file a claim since it worked perfectly before he shipped it.

    I pushed the power button and then the sleep button, and nothing.

    Any ideas? [​IMG]
     
  2. Chris Sherman

    Chris Sherman Second Unit

    Joined:
    Nov 30, 1998
    Messages:
    378
    Likes Received:
    0
    Rob,
    I hate to be the bearer of potentially bad news but as a longtime seller on ebay and HTF ,I can tell you from experience shippers never pay out on insurance claims. UPS or Fed Ex will say the package was inadequately packaged every time. Also, you can file the claim as well as the seller and , in fact probably should. What they will do is retrieve the package from you and inspect it and then return it to the shipper. You now have no prepro and no money. Then they will make a determination if it was damaged in shipping. The verdict will be no , that is a foregone conclusion. Did the box show obvious signs of damage ? Your best hope is the seller will refund your money. Now that I've given you the bad news let me tell you this in case your'e interested. I just upgraded my theater and will be selling my Outlaw 750 165 wattsx5 for $700.00 OBO . I also have a Marantz prepro Model AV560 DD/DTS with RC 2000 MKII remote The remote alone sold for $200 . The pre pro was purchased brand new on clearance for $500.00 with 3 year parts and labor warranty less than 2 weeks ago I will sacrifice for $399.00 delivered and guarantee no DOA. Works perfectly Highest rated Marantz prepro on Audio Review. I assume you have a nice 5 channel amp already. I would offer a packaged deal on both pieces for $1000.00. My user id is cdsherman on ebay. Good luck with your problem . I know how badly these things hurt. Go to the outlaw saloon and search the model 750 forum for horror stories on UPS and how useless the insurance is as they deny all claims. I've found the same thing with fed ex I shipped an expensive item on ebay and they damaged it, yet denied any responsibility. I did the right thing and refunded the buyers money which really put me in the hole, but I have worked hard to build my reputation on ebay and felt it was the honest thing to do. I hope your seller is a stand up guy and will make things right with you. Best of luck.
    Chris Sherman
     
  3. Robert Ma

    Robert Ma Second Unit

    Joined:
    Jun 18, 2001
    Messages:
    368
    Likes Received:
    0
    Rob,
    Chris is right. Unless there is obvious damage to the box UPS wont pay. Plus, the shipper needs to file the claim and you will have to send it back to him. So get your money back from him ASAP!
     
  4. Jerry Klawiter

    Jerry Klawiter Screenwriter

    Joined:
    Dec 3, 2000
    Messages:
    1,412
    Likes Received:
    0
    Give B&K a call,
    They just may surprise you on the cost
    of the fix, At the same time they will complete
    any past firmware & hardware service updates.
    Sounds like it could be a bad fuse.
    Or maybe loose internal card from shipping.
    The worse case would be a power supply.
     
  5. Chris Sherman

    Chris Sherman Second Unit

    Joined:
    Nov 30, 1998
    Messages:
    378
    Likes Received:
    0
    Jerry's suggestion is an excellent one, and one I had not thought of. Great customer service oriented companies like SVS, Outlaw and B&K will often step in and offer to help with problems like this at a nominal charge. You would not only get a working pre/pro but as Jerry said they could update you to the latest software. Good luck.
     
  6. Rob||Kur||

    Rob||Kur|| Stunt Coordinator

    Joined:
    May 9, 2003
    Messages:
    112
    Likes Received:
    0
    I got it working today!

    Thanks to Jerry for suggesting the loose cards. Seeing as I've built quite a few computers, I figured I could handle something like that and opened it myself. Turns out the
    positive wire to the power input was disconnected. I don't know how it happened, since when I got it hooked back up it was a very tight fit, but the unit powers on fine now.

    Thanks everyone.
     
  7. Chris Sherman

    Chris Sherman Second Unit

    Joined:
    Nov 30, 1998
    Messages:
    378
    Likes Received:
    0
    Rob ,
    Terrific! I know how relieved you must feel, enjoy the new toy!
    Chris
     
  8. Rob||Kur||

    Rob||Kur|| Stunt Coordinator

    Joined:
    May 9, 2003
    Messages:
    112
    Likes Received:
    0
    Thanks Chris, I appreciate the replies. Good look selling that Marantz unit. [​IMG]
     
  9. Jerry Klawiter

    Jerry Klawiter Screenwriter

    Joined:
    Dec 3, 2000
    Messages:
    1,412
    Likes Received:
    0
    Keep in mind that those hardware service Mods & firmware
    updates are still free.
    Give B&K a call to see what modifications may be needed.

    Enjoy the Ref! [​IMG]
     
  10. Jack Briggs

    Jack Briggs Executive Producer

    Joined:
    Jun 3, 1999
    Messages:
    16,738
    Likes Received:
    129
    Glad the problem appears resolved.

    Just a word of policy, guys: We prefer that "for sale" pitches and such take place only in the Hardware For Sale area. Or, in a case such as this, simply contact the party via e-mail or PM. Thanks!
     
  11. Chris Sherman

    Chris Sherman Second Unit

    Joined:
    Nov 30, 1998
    Messages:
    378
    Likes Received:
    0
    My bad . Won't happen again.
     
  12. Jack Briggs

    Jack Briggs Executive Producer

    Joined:
    Jun 3, 1999
    Messages:
    16,738
    Likes Received:
    129
    No pro', Chris.
     

Share This Page