What's new

B&K Ref 50 - New Owner Needs Help! (1 Viewer)

WayneF

Auditioning
Joined
Dec 12, 2001
Messages
8
I just set up my new B&K Ref 50 and have a question for any current owners of the Ref 50. I went into the speaker level calibration menu and the Ref 50 started sending the pink noise to all speakers. The front (Paradigm Studio 60s), center (Paradigm Studio CC), and side surrounds (Paradigm Cinema) all had very equal levels. The back surrounds (Paradigm Cinema) level was so low that I had to turn the level up to the +12 point. At this level it was still almost half the volume of the other speakers. I am using the B&K AV125.7 amp which does not have individual trim controls. I checked the wiring and it is correct. Am I doing something wrong? I cannot get both back surrounds anywhere near the level of the fronts or side surrounds. I think I may have a defective unit but I'm not sure. Any help would be appreciated!
 

Donnie Eldridge

Supporting Actor
Joined
Jan 3, 2001
Messages
761
I haven't encountered this problem with my unit. Have you tried swapping speaker wires for the side surrounds and the back surrounds on your amp? It's possible the issue may be there and not the unit itself.
 

Ted Pugh

Stunt Coordinator
Joined
Jan 13, 2003
Messages
108
Did you try looking at your B&K amp and make sure that you do not have the Balance button pushed in unless you are running balance cables. That could be your problem. I run the 200.5 and this happened at first until I depressed the balance buttons for my rear surrounds.

Ted
 

WayneF

Auditioning
Joined
Dec 12, 2001
Messages
8
You guys are correct. I swapped all the speakers and connections around and the problem was always in just those two amplifier channels. It was the balanced/unbalanced button being depressed. I checked them before installation but must have hit one during the hookup of my other components. I called B&K tech support and was on the phone with a knowledgable tech within two minutes. He knew exactly what was going on and we solved the problem in less than a minute. Kudos to B&K for unbelievable access to tech support!
 

Users who are viewing this thread

Forum Sponsors

Forum statistics

Threads
349,173
Messages
4,871,060
Members
142,505
Latest member
charlie87168
Recent bookmarks
0
Top