AV12 problem

Discussion in 'Home Theater Projects' started by David_Merrow, Sep 11, 2003.

  1. David_Merrow

    David_Merrow Stunt Coordinator

    Joined:
    Mar 25, 2001
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    0
    Hello, I was just wondering if anybody has had any problems with their Stryke AV12?

    The reason I ask is because my brother got one for his truck and the voice coil was broke. He sent that one back and got the new one yesterday and the voice coil is broke in that one. It is installed in a sealed 1.5cf box with a 600 watt amp.

    David
     
  2. Jake K

    Jake K Stunt Coordinator

    Joined:
    May 22, 2003
    Messages:
    132
    Likes Received:
    0
    Trophy Points:
    0
    How do you know it was broke? What was happening?
    My AV15 is just fine.
     
  3. Andrus_R

    Andrus_R Stunt Coordinator

    Joined:
    Oct 19, 2002
    Messages:
    109
    Likes Received:
    0
    Trophy Points:
    0
    Ditto what jake said, cept mine's av12
     
  4. David_Merrow

    David_Merrow Stunt Coordinator

    Joined:
    Mar 25, 2001
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    0
    He had someone look at it because it was making a loud noise.

    That is all I know about it though because he is in NC and I am in MI.
     
  5. Shawn Solar

    Shawn Solar Supporting Actor

    Joined:
    May 12, 2001
    Messages:
    763
    Likes Received:
    0
    Trophy Points:
    0
    Maybe he has a leaky box or air gap. I have two av12's each sealed. The only thing I had to do was tighten the binding posts cause they rattled[​IMG] I use banana plugs.
     
  6. Bryan Michael

    Bryan Michael Supporting Actor

    Joined:
    Mar 2, 2002
    Messages:
    564
    Likes Received:
    0
    Trophy Points:
    0
    i have a av15 in a 2 cube selaled box with 50%stuff and 1000 wats it runs like a dream. but i dont bump it that loud. it is also better than the 2 12 i had befor kicker xpl
     
  7. Andrus_R

    Andrus_R Stunt Coordinator

    Joined:
    Oct 19, 2002
    Messages:
    109
    Likes Received:
    0
    Trophy Points:
    0
    deleted
     
  8. John E Janowitz

    John E Janowitz Second Unit

    Joined:
    Oct 30, 2000
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    0
    Hi David,

    I'm waiting to hear back from TC on your brother's AV12. The first one obviously had something wrong with it. It almost sounded like the VC had come unwound and wires were rattling around inside. The second one he is claiming to have the same problem. We need to look into this because there have been very few problems with AV woofers. We need to determine what is different about his situation that could have caused this.

    I wanted to hear back from TC and determine what they say before making a decision on what to do with the second woofer. There are several possibilities of what may have happened. His were the only two I can think of that were sent by USPS. Possibly they are doing something to the packages, causing problems. Another possibility is either over/under powering. Overpowering is usually not as dangerous as underpowering and clipping the amplifier. It could also just be coincidence that 2 woofers were both bad the he received, but I did check the second before sending it and it was in perfect condition when it left here.

    TC was supposed to pull the first woofer apart friday and get back to me on what happened. They can tell if the driver was damaged to abuse, clipping the amp, etc, or if it was due to a build defect. I have not yet heard back from them, but will contact your brother and also send you an email as soon as I hear something.

    John
     

Share This Page