What's new

AV Receiver turns off when I switch to Blu-Ray HDMI port (1 Viewer)

Curt Gilker

Agent
Joined
Sep 5, 2002
Messages
38
This is a new development, as I have not changed anything in my setup for several years. Today, when I switched to the Blu-Ray player (using HDMI), the receiver turns off. this happens repeatedly. The other HDMI ports and inputs work fine (i.e. Roku, TV).

It is definitely the Blu-Ray player, as I changed it to another HDMI port and the same thing happened on the new HDMI port. Similarly, I switched to another HDMI cable, and the receiver still shut down.

Any ideas on how to troubleshoot further? Or just get a new Blu-Ray player?

Thanks in advance.
 

Clinton McClure

Rocket Science Department
Premium
Senior HTF Member
Joined
Jun 28, 1999
Messages
7,694
Location
Central Arkansas
Real Name
Clint
Just a thought but it sounds like the Blu-ray player may be overloading the receiver and possibly causing the thermal protection circuit to kick in.

Can you turn the receiver back on after it shuts off and get a Blu-ray to play or does it shut off every time?
 

JQuintana

BANNED
Joined
Aug 30, 2018
Messages
1,194
Real Name
Me
As silly as it sounds, may want to unplug power to both for a minute. The plug back in and test.
 

Curt Gilker

Agent
Joined
Sep 5, 2002
Messages
38
Just a thought but it sounds like the Blu-ray player may be overloading the receiver and possibly causing the thermal protection circuit to kick in.

Can you turn the receiver back on after it shuts off and get a Blu-ray to play or does it shut off every time?

My thought too, but I don't know why this would just start now (but I am no expert). And yes, the receiver shuts off every time.
 

John Dirk

Premium
Ambassador
HW Reviewer
Senior HTF Member
Joined
May 7, 2000
Messages
6,697
Location
ATL
Real Name
JOHN
This is a new development, as I have not changed anything in my setup for several years. Today, when I switched to the Blu-Ray player (using HDMI), the receiver turns off. this happens repeatedly. The other HDMI ports and inputs work fine (i.e. Roku, TV).

It is definitely the Blu-Ray player, as I changed it to another HDMI port and the same thing happened on the new HDMI port. Similarly, I switched to another HDMI cable, and the receiver still shut down.

Any ideas on how to troubleshoot further? Or just get a new Blu-Ray player?

Thanks in advance.
Sounds like a Consumer Electronics Control [CEC] issue to me. Check the Blu Ray players settings. Different companies may use different names but its basically a protocol that allows basic commands to be sent via HDMI to other capable devices. When you find it, disable it.
 

Users who are viewing this thread

Latest Articles

Forum statistics

Threads
356,514
Messages
5,114,792
Members
144,104
Latest member
Righ
Recent bookmarks
0
Top