ARGH, My Harman Kardon AVR-510 keeps shutting off on me!

Discussion in 'Archived Threads 2001-2004' started by Mike Kao, Nov 27, 2001.

  1. Mike Kao

    Mike Kao Second Unit

    Joined:
    Oct 31, 2000
    Messages:
    277
    Likes Received:
    0
    I've been having this problem for quite some time now, except recently it's been occuring quite frequently. You see sometimes I'll have this problem where the receiver keeps turning off either instantly or after 5-20 seconds after powering it on. It will keep doing this until it decides to start working again (maybe an hour or 2 or 3). At first I thought it might be the power conditioner it was connected to (panamax 1000+) but I tried plugging it into a separate surge suppressor and also straight into the wall outlet w/ the same results. I thought maybe it was drawing more current than was available so I turned off nearly everything in the room and house... the problem persisted. I quadruple checked all the connections to each speaker and to the receiver and even rewired the entire setup to make sure there aren't any bad connections... yet the problem still remains! I know it isn't a matter of speaker impedence either, b/c I disconnected my 4ohm rears to make sure that wasn't the problem. So now I'm lead to believe the receiver is defective. Any ideas that I could try before I'm forced to send it in for repair?
     
  2. Jerome Grate

    Jerome Grate Cinematographer

    Joined:
    May 23, 1999
    Messages:
    2,978
    Likes Received:
    6
    Unfortunately, you'll have to send it back for service or a complete replacement. Look on the bright side, this may be an opportunity to trade it in for the 520 since there out now.
     
  3. Lin Weiwen

    Lin Weiwen Stunt Coordinator

    Joined:
    Nov 12, 2001
    Messages:
    61
    Likes Received:
    0
    When I first purchased my Harman Kardon AVR300 in Jan, it was working fine and beautiful....well.....for a week. The second week, the receiver wasn't producing any sound at all, not even the test tones. I checked the speaker connections and everthing was correct. So I figured the problem lies with the rcvr itself and I made a call to the my local Harman Kardon technician and requested for a new one. I was quite pissed too. The next day, he arrived and switched the faulty set with the new one. It has been working fine ever since. [​IMG]
    So Mike..I suggest you give your local HK technician a call and get his butt down to your place to check out the rcvr. Hope you still have the warranty card! Good luck![​IMG]
     
  4. Sheldon

    Sheldon Stunt Coordinator

    Joined:
    Sep 5, 2001
    Messages:
    176
    Likes Received:
    0
    I also have the 510 and the problem that I was having was,what I considered,exceptional heat across the middle top of the receiver.I sent an email to H/K and the assistant production manager answered right away and basically told me not to sweat it,that that was within their operating temperature.He also told me that not to worry unless the unit was turning itself off,so I would definately send them an email.More than likely,you will have to bring the avr in for service.
     

Share This Page