Anyone else encounter this?

Discussion in 'Archived Threads 2001-2004' started by Brad Wood, Jan 29, 2003.

  1. Brad Wood

    Brad Wood Stunt Coordinator

    Joined:
    Nov 25, 2002
    Messages:
    88
    Likes Received:
    0
    Helloooo all!

    I encountered something weird last weekend. I sold my Adcom 760 so that I could begin the saving process to pick up either an Anthem AVM20 or a Ref 50. When I packed up the 760, I went back to my old Marantz AV600 pro-logic pre and I discovered something kind of odd. I think the AV600, even in pro-logic, sounds better? The bass was lower, tighter, and flatter. The center channel came out front more, but the mix between L, C, and R was still even. And overall, it seemed like the balance between music and dialogue in movies was more even. There's no doubt I do miss the full range stereo surrounds, but not that much. And for 2 channel, there was absolutely no comparison, the Marantz blew it away.

    Is this something that is brand specific here, or has anyone else run into this? Now I'm thinking that instead of upgrading my processor, I'll round out my M&K system with the 400 watt dual 12 sub, or replace the M&K 1610 surrounds with the super sexy powered tri-poles! My system sounds fine now, and I think maybe I'll get my speaker system ready for my dream room and wait until manufacturers can actually come out with an upgradeable pre/processor, that they actually use as a platform for upgrades, rather than selling a new processor every two years. Anyone have any thoughts on this?
     
  2. Brad Wood

    Brad Wood Stunt Coordinator

    Joined:
    Nov 25, 2002
    Messages:
    88
    Likes Received:
    0
    Geez.....quiet down everybody! Don't everyone babble at once.........
     

Share This Page