All of a sudden my PS2 displayes in Black and white...

Discussion in 'Archived Threads 2001-2004' started by Adam C., Feb 8, 2003.

  1. Adam C.

    Adam C. Stunt Coordinator

    Joined:
    Apr 10, 2002
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    0
    i have my Ps2 hooked up to my receiver with the Monster component video cable. Then from the receiver to my TV with some radio shack gold series componet video cables. Today I got a new monster power surge protector. I unplug everything from the old surge protector. I plug it all into the monster power surge protector. I turn on the PS2 and now everything is in black and white. What did I do?
     
  2. Adam C.

    Adam C. Stunt Coordinator

    Joined:
    Apr 10, 2002
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    0
    BTW, I just hooked up the PS2 with the cables that came with it and it is fine. How could the Monster cables just stop working all of a sudden?
     
  3. NickSo

    NickSo Producer

    Joined:
    Jul 2, 2000
    Messages:
    4,260
    Likes Received:
    0
    Trophy Points:
    0
    Real Name:
    Nick So
    Nevermind, brain fart [​IMG]
     
  4. Brian Ruth

    Brian Ruth Supporting Actor

    Joined:
    Jun 21, 2002
    Messages:
    563
    Likes Received:
    0
    Trophy Points:
    0
    Adam: My guess is that one of the cables is malfunctioning.

    I think I can remember hooking my PS2 up incorrectly with component cables before (Audio red in Video Red spot), and the color went into black and white. My guess is that is what happens when a cable goes bad.

    I'd call Monster and see if you can get your cables exchanged. Considering the price, there's no reason those cables shouldn't outlast your system.
     
  5. Camp

    Camp Cinematographer

    Joined:
    Dec 3, 1999
    Messages:
    2,301
    Likes Received:
    0
    Trophy Points:
    0
    What happens if you run the Monster cables directly from the PS2 to the TV? (bypassing your receiver)

    If it's still messed up after trying that I'd agree that the Monster cable is defective. If it works, it's a pretty good sign you have the cables running from the receiver to the TV mixed up (i.e. red to green instead of red to red).
     
  6. Adam C.

    Adam C. Stunt Coordinator

    Joined:
    Apr 10, 2002
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    0
    ok, i hooked it up directly to the TV and it worked, then I hooked it up to the receiver and it worked again. Who knows what was wrong.
     

Share This Page