1. We suffered a brief outage this morning when our host noticed that HTF needed to be moved to a different server due to a hardware failure. That work is now complete. Please post in the feedback area if you have any issues.
    Dismiss Notice

Adcom GFA2 problem

Discussion in 'AV Receivers' started by Jeff H, Nov 27, 2003.

  1. Jeff H

    Jeff H Stunt Coordinator

    Joined:
    Oct 8, 1999
    Messages:
    189
    Likes Received:
    0
    I have an Adcom GFA2 amp. One of the channels only works when you crank up the volume. It will stay on as long as the volume is high. Once you trun the sound down, the channel will cut out. Anyone have any ideas what the problem could be? I am not going to have it serviced. Thanks, Jeff
     
  2. MichaelDDD

    MichaelDDD Supporting Actor

    Joined:
    Sep 29, 2003
    Messages:
    616
    Likes Received:
    0
    Real Name:
    Mike
    Have you tried another set of RCA cables? Possibly there's a bad connection/solder joint in one of the pairs?

    Swap the L/R and see if the problem changes channels. If it does, there's your answer.

    If it doesn't, you have to isolate whether it's a preamp or poweramp problem. Find another source (walkman, sound card out, whatever) and plug that into the amp's inputs. If the problem persists, your amp's bad.

    Good luck. [​IMG]
     
  3. Jeff H

    Jeff H Stunt Coordinator

    Joined:
    Oct 8, 1999
    Messages:
    189
    Likes Received:
    0
    It is definitely the amp. I have done all the cable and source swaps. It is an extra amp, so I am not real worried about it. Thanks
     

Share This Page