Aargh! Could not get two pc's networked...

Discussion in 'Computers' started by Ted Lee, Jul 28, 2003.

  1. Ted Lee

    Ted Lee Lead Actor

    Joined:
    May 8, 2001
    Messages:
    8,390
    Likes Received:
    0
    Trophy Points:
    0
    hi all -

    i feel like an arse, but for the life of me, i couldn't get this working.

    i worked on this for about three hours with no luck. here's the deal.

    1. two pc's (both running xp home). desktop is called "office", laptop is called "cfsinc"
    2. one linksys wireless router and the doo-hickey for the laptop

    i was able to connect the two pc's (changed ssid, enabled 128wep) with no problem. the wireless connection is solid and the laptop can surf the internet.

    however, i want both computers to be able to share files from the other at the root level. my friend would like to be able to do his work on the laptop, then go into the office and print.

    or, even more ideally, print directly from the laptop. but i told him this would require an additional 150.00 print server doo-hickey.

    so, my major problem was trying to get the two pc's to see eachother. so, here's what i did.
    1. right-click c drive on desktop - shared folder name is "office"
    2. on the laptop, try to map a network drive to \officeoffice (computer namefolder name)[/list=1] should be easy enough correct? however the laptop would tell me it couldn't find the name. then (i'm not 100% sure on this now) when i tried to browse via the network neighborhood on the laptop, it would see the desktop, but i couldn't access the share. i think i got some error about "no permission to view network resource".

      somebody freakin' help me!!! i have a wireless setup at my house and did not run into this problem, so i'm not sure what i'm doing wrong for my friend???
     
  2. John_Bonner

    John_Bonner Supporting Actor

    Joined:
    Oct 25, 2000
    Messages:
    664
    Likes Received:
    0
    Trophy Points:
    0
    Do you have ZoneAlarm or some other firewall running?
    If so, try to connect again and when it fails open your firewall software and allow the ip of the other machine to be able to connect.
     
  3. Rob Gillespie

    Rob Gillespie Producer

    Joined:
    Aug 17, 1998
    Messages:
    3,632
    Likes Received:
    5
    Trophy Points:
    0
    They need to be made a member of the same workgroup.
     
  4. Ted Lee

    Ted Lee Lead Actor

    Joined:
    May 8, 2001
    Messages:
    8,390
    Likes Received:
    0
    Trophy Points:
    0
    thx guys. they did have some norton stuff running, but i disabled it. i will double-check to see what that stuff is doing.

    rob - both pc's are part of the same workgroup. i verified that via the computer name tab. is that what you mean or do i need to do it some other way?

    i was wondering if it was some sort of user account issue, but i don't know much about that.
     
  5. Rob Gillespie

    Rob Gillespie Producer

    Joined:
    Aug 17, 1998
    Messages:
    3,632
    Likes Received:
    5
    Trophy Points:
    0
    OK, sounds like an accounts issue then.

    What accounts are you using on each machine? If you're using accounts with no passwords set (i.e. you just hit enter when choosing a password) then there's a security setting you need to change.
     
  6. Ted Lee

    Ted Lee Lead Actor

    Joined:
    May 8, 2001
    Messages:
    8,390
    Likes Received:
    0
    Trophy Points:
    0
    >> What accounts are you using on each machine?

    umm...how do i tell? :b i know when he logs on, he's using an account with admin privileges. i checked that. i know he setup more then one account (one for his wife, one for his kids, etc.) - but i'm sure his personal one has admin rights.

    do you know where i go to check security settings?
     
  7. Mike__D

    Mike__D Supporting Actor

    Joined:
    Dec 27, 2000
    Messages:
    617
    Likes Received:
    0
    Trophy Points:
    0
    Ted,

    This does sound like a user name issue. Unless both PC's have the same username accounts with the same password, it will not automatically connect, you'll have to provide a username and password.

    Your best bet is to make a remote user account. On the Office PC, go to the Control Panel. Switch to Category View if it's not already. Then click User Accounts. Under Choose Task, click Create a New Account. Type a username for this account, then on the next screen, set it up as either Admin or Limited. If you are just transfering files, Limited should suffice.

    After creating the account, click the account to create a password (if you want one). Now on the laptop, browse to the Office PC and click the Office folder. A login box should appear. Enter the username you created and the password you created. You should be in.

    Other ways to do this:

    Login to the Office folder with the same username and password of the main Office PC account or enable the Guest Account on the Office PC (this is off by default for security reasons).

    Mike D.
     
  8. JamesHl

    JamesHl Supporting Actor

    Joined:
    May 8, 2003
    Messages:
    813
    Likes Received:
    0
    Trophy Points:
    0
    If you're running norton it might also be blocking netbios or smb ports.
     
  9. Ted Lee

    Ted Lee Lead Actor

    Joined:
    May 8, 2001
    Messages:
    8,390
    Likes Received:
    0
    Trophy Points:
    0
    thanks mike - i'm going to forward your info to my friend. we'll see what happens.

    everyone keep em comin' and cross your fingers.

    i do appreciate the help guys! [​IMG]
     
  10. Vince Maskeeper

    Vince Maskeeper Producer

    Joined:
    Jan 18, 1999
    Messages:
    6,499
    Likes Received:
    0
    Trophy Points:
    0
    I have had endless problems with 2000 and XP-- if you have an account that doesn't have the same account on the other machine it won't work. There is no elegant solution other than using all the same usernames...

    But the thing is- if that is the issue- you can usually BROWSE to the network share via network places and then when you try to open the folder you'll be prompted for a password (god knows what pass will make this work, as I've tried everything)... this means the username logged in doesnt have permission on the other machine.

    But try setting up a user account on the other machine for the account you use on laptop (make sure the pword is the same).

    -V
     
  11. Ted Lee

    Ted Lee Lead Actor

    Joined:
    May 8, 2001
    Messages:
    8,390
    Likes Received:
    0
    Trophy Points:
    0
    thanks vince - i've already forwarded this to my friend, so i'll keep everyone posted.

    sounds like the user account is the way to go...
     
  12. Vince Maskeeper

    Vince Maskeeper Producer

    Joined:
    Jan 18, 1999
    Messages:
    6,499
    Likes Received:
    0
    Trophy Points:
    0
    I really wish there was a way around this aside from setting up a domain controller and doing real user control (which you cant do with XP home anyway). I tried enabling the guest account in XP and it did seem to allow non-authenticated users for a while but then stopped (and in retrospect I'm not 100% sure it ever actually worked).

    In the end I set up every machine in the house to log in with one of two accounts: User and Administrator... which basically murders the whole point of user switching and individual desktops... but it seems the most reliable way to allow universal access to shared folders.

    It's funny that Microsoft seems to think every house should be running a small network-- yet professional networking people can't get an average home network running consistently.

    Networking functionality is the one thing i miss about 98. When I tell 2000 security settings to allow "everyone" I mean EVERYONE-- not just the users in the everyone group. Also, 98 allowed you to password protect individual folders while XP doesn't (at least not home).

    One step forward, two steps back.

    -Vince
     
  13. Mike__D

    Mike__D Supporting Actor

    Joined:
    Dec 27, 2000
    Messages:
    617
    Likes Received:
    0
    Trophy Points:
    0
    Vince,

    The difference between '98 and 2000/XP is the NTFS file system. This allows user restrictions to be set a 2 different levels, at the share level and at NTFS level. The most restrictive level supersedes the other. For example, if you have a shared folder you allowed userX full access through the share, but the NTFS allows only read access, userX will only be able to read that shared folder.

    You do not need to have the same usernames on both computers. Once you click on the shared folder, a log in box should appear, and you'll need to enter a valid username & password which resides on the shared PC. I have a few PC's in my workgroup at work ('98, 2K, & XP), and share folders and move files between them, even though they don't have the same usernames and passwords.

    2000 & XP's networking capabilities are far better and more powerful than '98's. I completely disagree they took steps backwards. I find the workgroup network capabilities to be far more reliable than '98's ever were.

    Mike D.
     
  14. Mike__D

    Mike__D Supporting Actor

    Joined:
    Dec 27, 2000
    Messages:
    617
    Likes Received:
    0
    Trophy Points:
    0
    Forgot to mention, to view NTFS file permissions tab in XP, you first must clear the Use Simple File Sharing box under the view tab in Folder Options (found in Appearance and Themes).

    Right-click any file or folder, select properties, and you'll see the Security tab for setting permissions. Please note, do not change settings you are unsure of!!
     
  15. Vince Maskeeper

    Vince Maskeeper Producer

    Joined:
    Jan 18, 1999
    Messages:
    6,499
    Likes Received:
    0
    Trophy Points:
    0


    mine pops up a login with no ability to change a username (none is listed) with just a blinking password box. I tried every pword for accounts on the machine, starting with the administrator and working my way through every account- none works.

    Once I walk in the other room and add the 98 username and pword to the 2000 account list, everything works great.

    -Vince
     
  16. Kyle McKnight

    Kyle McKnight Cinematographer

    Joined:
    Mar 8, 2001
    Messages:
    2,504
    Likes Received:
    0
    Trophy Points:
    0
    What sucks about my setup...I've got one XP Home system, and one XP Pro. I have them networked through a linksys 4 port switch. Both computers are in the same workgroup, but I can't even see the other computer in "my network places." I've tried so many things to no avail.
     
  17. Mike__D

    Mike__D Supporting Actor

    Joined:
    Dec 27, 2000
    Messages:
    617
    Likes Received:
    0
    Trophy Points:
    0
    Vince,

    Are you trying to connect to the 2000 PC through the 98 PC? If so, that will not work if the 2000 drive is formatted in NTFS. 98 does not natively have the ability to view NTFS partitions.

    A work around for this is to create a separate partition on the 2000 PC formatted as FAT32. The 98 PC will then be able to see that partition.

    Mike D.
     
  18. Vince Maskeeper

    Vince Maskeeper Producer

    Joined:
    Jan 18, 1999
    Messages:
    6,499
    Likes Received:
    0
    Trophy Points:
    0


    Yes, although I dont think it should matter as the share is not really viewed "directly". In a networking configuration, it's not like the drive is inside the 98 machine- instead the network's master browser machine is simply telling the other machines what files are present on the 2000 share.

    I am readily able to see and use files on a NTFS partition from a 98 machine all the time, I just have to make sure each machine has the same user accounts. If all machines are logged in a "user" or "administrator" all my 98 machines can see XP and 2000 shares just fine (including changing and deleting files).

    -Vince
     
  19. Mike__D

    Mike__D Supporting Actor

    Joined:
    Dec 27, 2000
    Messages:
    617
    Likes Received:
    0
    Trophy Points:
    0
     
  20. Rob Gillespie

    Rob Gillespie Producer

    Joined:
    Aug 17, 1998
    Messages:
    3,632
    Likes Received:
    5
    Trophy Points:
    0
    Vince, I don't think there's a way around your problem with 98 apart from what you've already tried. 95/98 basically lets anyone onboard whereas NT based Windows requires an account to be there.

    The only way you can do it is using the Guest account. Might be worth trying that again.
     

Share This Page