4K UHD Disc Playability Issues

Discussion in 'Blu-ray and UHD' started by Edwin-S, Sep 13, 2017.

Tags:
  1. Edwin-S

    Edwin-S Lead Actor
    Supporter

    Joined:
    Aug 20, 2000
    Messages:
    6,814
    Likes Received:
    694
    Trophy Points:
    9,110
    I searched for a thread like this and didn't find one, so I thought I would start one where people can report problems with UHD discs not playing. If there is a similar thread to this one, feel free to merge this one with it.

    So far, I have had issues with two discs as follows:

    Tiltle: Crouching Tiger, Hidden Dragon
    Publisher: Sony
    Player: Samsung K_8500
    Player Firmware: Latest
    Disc Issue: Will not read

    Tiltle: The Mummy (1999)
    Publisher: Universal
    Player: Samsung K_8500
    Player Firmware: Latest
    Disc Issue: Gives message "disc does not meet specifications". Fails to load.
     
  2. Edwin-S

    Edwin-S Lead Actor
    Supporter

    Joined:
    Aug 20, 2000
    Messages:
    6,814
    Likes Received:
    694
    Trophy Points:
    9,110
    I posted this to the wrong area. It should be in the Blu-ray and UHD media area. Please move. Thanks.
     
  3. jcroy

    jcroy Cinematographer

    Joined:
    Nov 28, 2011
    Messages:
    2,963
    Likes Received:
    828
    Trophy Points:
    4,110
    Real Name:
    jr
    Do any of these discs show signs of rotting and/or any other defects already?
     
  4. Edwin-S

    Edwin-S Lead Actor
    Supporter

    Joined:
    Aug 20, 2000
    Messages:
    6,814
    Likes Received:
    694
    Trophy Points:
    9,110
    None that I could see.
     
  5. dpippel

    dpippel HTF Premium Member
    Supporter

    Joined:
    Feb 24, 2000
    Messages:
    5,365
    Likes Received:
    1,675
    Trophy Points:
    9,110
    Location:
    Yoyodyne Propulsion Systems
    Real Name:
    Doug
    The first run of Crouching Tiger, Hidden Dragon 4K UHD had a manufacturing issue that caused some players to not recognize the disc. There was never a recall but the problem was corrected in subsequent runs. If you contact SPHE I'll bet they'd replace it for you.
     
  6. DavidMiller

    DavidMiller Screenwriter
    Supporter

    Joined:
    Feb 16, 2004
    Messages:
    1,036
    Likes Received:
    389
    Trophy Points:
    1,610
    Location:
    Kirkland, Wa
    Real Name:
    David Miller
    Both of those play fine on my Oppo, I don't have my Samsung to test them on anymore sorry.
     
  7. Todd Erwin

    Todd Erwin Producer
    Reviewer

    Joined:
    Apr 16, 2008
    Messages:
    3,139
    Likes Received:
    292
    Trophy Points:
    4,110
    Location:
    Hawthorne, NV
    Real Name:
    Todd Erwin
    Sounds like they are bad discs. I would contact the studios for a replacement.

    On a similar note, I've had random loading issues with The Cabin in the Woods on my Sony UBP-X800 player. The solution was to first eject and re-insert the disc. If that did not work, then ejecting the disc, unplugging the power on the player for 30 seconds, then reconnecting power and inserting the disc.

    What us early adopters must suffer through with these first-gen players.....:huh:
     
  8. Scott Merryfield

    Scott Merryfield Executive Producer

    Joined:
    Dec 16, 1998
    Messages:
    12,629
    Likes Received:
    1,282
    Trophy Points:
    9,110
    Location:
    Michigan
    Make sure the disc is completely clean, too. I had one disc that had issues loading in my Sony player and looked clean to the naked eye. I ran it under cold water and wiped it dry with a microfiber cloth and it then played fine.
     
  9. Scott Merryfield

    Scott Merryfield Executive Producer

    Joined:
    Dec 16, 1998
    Messages:
    12,629
    Likes Received:
    1,282
    Trophy Points:
    9,110
    Location:
    Michigan
    Lousy 4G coverage where I'm currently at. Sorry about the double posts. Don't believe Verizon's commercials. Lol.
     

Share This Page