Jump to content



Sign up for a free account to remove the pop-up ads

Signing up for an account is fast and free. As a member you can join in the conversation, enter contests and remove the pop-up ads that guests get. Click here to create your free account.

Photo
- - - - -

My thoughts of JVC XV-SA75..


  • You cannot start a new topic
  • Please log in to reply
33 replies to this topic

#21 of 34 OFFLINE   Andrew_Ballew

Andrew_Ballew

    Second Unit



  • 295 posts
  • Join Date: Feb 21 2002

Posted March 14 2002 - 12:50 PM

Quote:
I just got this player today, i had some questions about DVD-audio since this is my first player and experiance with it. IF im hooking it up with a digital cable to my reciever. Do i need the 2 component cables also, for it to work. I cant seem to get any sound out of it, but regular dvds play fine with sound.


You will have to hook it up via the 5.1 analog pre-outs on the player. Route the audio cables to the 5.1 channel input on your receiver.

This is currently the only way that the high resolution DVD-audio tracks can be played back.

Andrew

#22 of 34 OFFLINE   Kevin T.

Kevin T.

    Extra



  • 21 posts
  • Join Date: Feb 18 2002

Posted March 14 2002 - 02:22 PM

so just get a decent pair of the red/white cables?

#23 of 34 OFFLINE   Sean Moon

Sean Moon

    Screenwriter



  • 2,045 posts
  • Join Date: Jan 25 2001

Posted March 14 2002 - 04:13 PM

OK...now the player isnt loading certain discs. Wont even boot up Emperor's new groove. Still has Star Wars booting issues. What's up? Do I have a lemon?
http://doctordoom.blogspot.com

We must stand in awe of the infinite capacity of the human mind to reject the introduction of useful knowledge.

#24 of 34 OFFLINE   Paul Clarke

Paul Clarke

    Supporting Actor



  • 998 posts
  • Join Date: Jan 29 2002

Posted March 14 2002 - 04:46 PM

Probably the reason it was an open box. Send it back if you can.
"By the blood of our people are your lands kept safe."

#25 of 34 OFFLINE   Adil M

Adil M

    Supporting Actor



  • 922 posts
  • Join Date: Nov 21 2001

Posted March 14 2002 - 04:53 PM

My guess is it's defective. I have yet to have any problems at one dvd per day.

#26 of 34 OFFLINE   Andrew_Ballew

Andrew_Ballew

    Second Unit



  • 295 posts
  • Join Date: Feb 21 2002

Posted March 15 2002 - 07:58 AM

Quote:
so just get a decent pair of the red/white cables?



Yeah- any good 50 ohm cable will do. Might I suggest Acoustic Research audio cables? You can get them at Best Buy, I think they run something like 12-14 dollars a pair. A bargain for what you get, if you ask me.

Cheers

Andrew Ballew

#27 of 34 OFFLINE   Kevin T.

Kevin T.

    Extra



  • 21 posts
  • Join Date: Feb 18 2002

Posted March 15 2002 - 09:01 AM

ok, i figured it out, i needed 6 cables to plug into my multi channel imputs in my amp, everything works great now, Thanks for the replys
Kevin

#28 of 34 OFFLINE   Bry_DD

Bry_DD

    Second Unit



  • 345 posts
  • Join Date: Dec 29 2000

Posted April 02 2002 - 01:10 AM

Well, I decided to keep this player after all. The more I watch movies with this player the more I see the diff. with prog and interlace player. It's so much better with my mits 46805. Also the DVD-A play back is sweet.. Listen to The Eagles Hotel California and Barenaked Ladies in DVD-A, all I can say is WOW! Fellas that expirience dvd-a know's what I'm talking about. Now all I'm waiting is my svs25-31cs..I will be expecting it tomorrow. Its goint to be a long day today and tomorrow.. Posted Image

Hvae a good day fellas!
Bry

#29 of 34 OFFLINE   Brian Corr

Brian Corr

    Supporting Actor



  • 544 posts
  • Join Date: May 10 1999

Posted April 02 2002 - 03:42 AM

I've got one for sale in the hardware classifieds if anyone is interested.

#30 of 34 OFFLINE   Mark_Wilson

Mark_Wilson

    Screenwriter



  • 1,809 posts
  • Join Date: Jul 27 2000

Posted April 03 2002 - 03:46 AM

I've got a 75 and it Does have the Chroma Bug. It is masked though, so its not as noticeble as the old Toshiba players.

EDIT: I stand corrected. I must have been thinking of a different player. I was not able to verify my previous statement. I did find out that all mediamatics players do NOT have the chroma upsample bug.

#31 of 34 OFFLINE   Paul Clarke

Paul Clarke

    Supporting Actor



  • 998 posts
  • Join Date: Jan 29 2002

Posted April 03 2002 - 05:26 AM

Exactly what does SSpears know that John Kotches et al do not know? Please post a DIRECT link.
"By the blood of our people are your lands kept safe."

#32 of 34 OFFLINE   Justin Gates

Justin Gates

    Agent



  • 48 posts
  • Join Date: Feb 26 2001

Posted April 03 2002 - 05:36 AM

From what I can recall from reading about Stacey Spears findings is that the player did NOT have the chroma bug.

#33 of 34 OFFLINE   Stephen Houdek

Stephen Houdek

    Second Unit



  • 325 posts
  • Join Date: Jan 21 2002

Posted April 03 2002 - 11:41 AM

I have the SA70 model and its progressive output is spectacular. Can't understand anyone thinking it to be horrible.

#34 of 34 OFFLINE   dan fritzen

dan fritzen

    Second Unit



  • 304 posts
  • Join Date: Mar 19 2001

Posted August 06 2003 - 03:14 PM

Quote:
Can't understand anyone thinking it to be horrible.


I just hooked up teh sa75 to my sony 34xbr800 and progressive mode is horrible the picture is not stable, it actually moves and will not stay still, someone on AVS said they had the same problem too. I am goign to complain to JVC until they replace or fix it.
"Other than that Mrs. Lincoln how did you enjoy the show?"




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


Forum Nav Content I Follow