-

Jump to content



Photo
- - - - -

Rotel RLC-1040 Power Conditioner Issue


  • You cannot start a new topic
  • Please log in to reply
2 replies to this topic

#1 of 3 OFFLINE   Andrew Pezzo

Andrew Pezzo

    Second Unit

  • 483 posts
  • Join Date: Mar 17 2003

Posted August 23 2014 - 06:17 AM

The front display of the unit reads the following:

 

FAIL:

Relay weld

 

In addition to that the lights for the Line Boost and Line Trim were alternating between each other.  I looked in the manual for possible solutions and they only one offered was to unplug the unit and the issue may reset itself.  Well that didn't happen, still showing the same message.  Oddly everything plugged into it still works but I am guessing its no longer providing any protection.  Couldn't find anything online about this.  Is the unit essentially dead?

 

If it is dead can anyone offer a comparable replacement? 

 



#2 of 3 OFFLINE   schan1269

schan1269

    HTF Expert

  • 13,928 posts
  • Join Date: Jul 04 2012
  • Real Name:Sam
  • LocationChicago-ish/NW Indiana

Posted August 23 2014 - 11:33 AM

Any UPS with voltage regulation (I can't think one that doesn't), pure sine wave...if you have to have it.

CyberPower 1500.

#3 of 3 OFFLINE   Andrew Pezzo

Andrew Pezzo

    Second Unit

  • 483 posts
  • Join Date: Mar 17 2003

Posted August 24 2014 - 04:45 AM

In looking for a replacement I found an APC unit that the Rotel is based on, basically same thing with different shell.  I was going to get a Panamax MR4300 but realized I need something with at least 10 outlets.  And best part is the APC is going for half of what I paid for the Rotel since APC no longer makes this particular unit. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users