-Not Logged In-

Jump to content

Sign up for a free account to remove the pop-up ads

Signing up for an account is fast and free. As a member you can join in the conversation, enter contests and remove the pop-up ads that guests get. Click here to create your free account.

- - - - -

Help: Epson 5020 Problem

  • You cannot start a new topic
  • Please log in to reply
3 replies to this topic

#1 of 4 OFFLINE   djtech2k


    Stunt Coordinator

  • 54 posts
  • Join Date: Jan 12 2013

Posted July 23 2014 - 05:34 PM

I have an Epson 5020 that is just over 1 year old.  It was professionally installed and has not been used very much at all.  About a month ago it started having an issue and I need help to resolve it.  As of now, when you turn it on it begins to warm up and about when the picture starts to load, the light labeled "temp" lights up and the projector closes up.  The lens closes and it sounds like the fans continue to run. I have tried many times and it does the same all the time.  I tried resetting the power and removing the air filter but it doesn't change.  I have talked to Epson, but the only choice they give me is to uninstall it and send it back.  I paid a lot of money to have it installed so I am hesitant to lose all the settings and install that I paid for.


Any ideas on how to fix this thing?

#2 of 4 OFFLINE   schan1269


    HTF Expert

  • 16,779 posts
  • Join Date: Jul 04 2012
  • Real Name:Sam
  • LocationChicago-ish/NW Indiana

Posted July 23 2014 - 05:39 PM

Remove it and send it back.You could check to see if the vent is full of dust first.

#3 of 4 OFFLINE   Sam Posten

Sam Posten


  • 19,701 posts
  • Join Date: Oct 30 1997
  • Real Name:Sam Posten
  • LocationAberdeen, MD & Navesink, NJ

Posted July 31 2014 - 07:20 AM

Yep sounds like dust to me.

I lost my signature and all I got was this Nutter t-shirt

HTF Rules

Classified Sales Rules

UV Sales New Clarifications

#4 of 4 OFFLINE   djtech2k


    Stunt Coordinator

  • 54 posts
  • Join Date: Jan 12 2013

Posted August 01 2014 - 02:58 AM

When I removed the dust filter, it was almost spotless.  I even left the filter out and tried to power it on, but nothing changed.  I have left it unplugged for a few days now and I am going to try it again this weekend, as suggested by someone else.  Otherwise, I guess I am a bit screwed and have to take it down and send it off.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users