Jump to content



Photo
- - - - -

Problem connecting DVD to LED Flat panel


  • You cannot start a new topic
  • Please log in to reply
5 replies to this topic

#1 of 6 LilBro

LilBro

    Member

  • PipPip
  • 13 posts
  • Join Date: Jan 17 2007

Posted March 02 2013 - 01:40 PM

My daughter & her fiance gave us their Westinghouse LD4655VX television. I connected our Panasonic DVDCV51 player to it using the RGB video9 & optical audio connection. Unfortunately, when I play a disc, I get serious buzz on the audio the the video is B/W only. Where would my connections be mucked up? Or is the Panny dying? Thank you.

#2 of 6 schan1269

schan1269

    HTF Expert

  • 12,030 posts
  • Join Date: Jul 04 2012
  • Real Name:Sam
  • LocationChicago-ish/NW Indiana

Posted March 02 2013 - 01:52 PM

My first guess(cause I haven't looked at either one yet)... The Component input on the TV only works when the audio is connected correctly... That TV, I assure you, does not have an optical input. You need to connect the analog red/white with the component. I will be looking at the DVD player regardless.

#3 of 6 schan1269

schan1269

    HTF Expert

  • 12,030 posts
  • Join Date: Jul 04 2012
  • Real Name:Sam
  • LocationChicago-ish/NW Indiana

Posted March 02 2013 - 01:55 PM

I will also fathom a guess that the TV may not digest RGB, so you might have to switch the DVD player to YCrBr(or the other way).

#4 of 6 schan1269

schan1269

    HTF Expert

  • 12,030 posts
  • Join Date: Jul 04 2012
  • Real Name:Sam
  • LocationChicago-ish/NW Indiana

Posted March 02 2013 - 02:01 PM

Now I know the problem... That TV does not use the RGB(which I assume you meant the component, red/green/blue) connector...cause it doesn't have one. The only thing you can use is a standard composite cable... http://www.amazon.co...composite cable Considering how cheap an upconverting 1080P DVD player is...I'd get one... http://www.amazon.co...words=1080p dvd

#5 of 6 LilBro

LilBro

    Member

  • PipPip
  • 13 posts
  • Join Date: Jan 17 2007

Posted March 05 2013 - 09:52 AM

I misnamed the connection. I used high quality composite cables. Today I double checked the connections to make sure the Pr/Pb/Y cables on the DVD were connected to the correct posts on the TV. No go. The picture is B/W whether a disc is in or I just use the Panny's menu. The sound is thru the optical out to my 5.1 receiver. Beaucoup 60Hz hum on the TV.

#6 of 6 schan1269

schan1269

    HTF Expert

  • 12,030 posts
  • Join Date: Jul 04 2012
  • Real Name:Sam
  • LocationChicago-ish/NW Indiana

Posted March 05 2013 - 12:09 PM

That tv doesn't have a PrPbY connection.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users