Jump to content



Photo
- - - - -

Epson 5020 problem help!


  • You cannot start a new topic
  • Please log in to reply
5 replies to this topic

#1 of 6 arjunsud

arjunsud

    Advanced Member

  • PipPipPip
  • 53 posts
  • Join Date: Jan 02 2013

Posted January 17 2013 - 06:25 PM

Hi I just got a brand new Epson 5020. It was working fine for a few days but i was watching Tron 3D today and it randomly just shut off? I disconnected it for 30 minutes and still nothing . Checked the power connection and its connected properly. Projector wont turn on and no lights. During the movie aprox 1hr and 30 mins in it just turned off? Please Help!

#2 of 6 Jim Mcc

Jim Mcc

    Advanced Member

  • PipPipPip
  • 3,710 posts
  • Join Date: Feb 11 2004
  • Real Name:Jim
  • LocationOconomowoc, WI.

Posted January 17 2013 - 07:18 PM

I would call Epson ASAP!! It sounds like a defective unit.

#3 of 6 schan1269

schan1269

    HTF Expert

  • 12,029 posts
  • Join Date: Jul 04 2012
  • Real Name:Sam
  • LocationChicago-ish/NW Indiana

Posted January 17 2013 - 11:14 PM

As long as you bought it authorized, you have a warranty.

#4 of 6 Jason Charlton

Jason Charlton

    Advanced Member

  • 2,700 posts
  • Join Date: May 16 2002
  • Real Name:Jason Charlton
  • LocationBaltimore, MD

Posted January 18 2013 - 01:57 AM

That sort of thing is not unheard of, in fact it happened to me, too.  The first Mitsubishi projector I got died after about 30 minutes of use.  I had purchased the projector through projectorpeople.com and got in touch with them immediately.  They sent a replacement unit right away and a shipping label for me to return the defective unit direct to Mitsubishi.


The process was easy and pain-free and I have not had any problems with the second unit in nearly 6 years of use (I'm on my second bulb).


Are you new to the Home Theater Forum? Stop by the New Member Introductions area and introduce yourself! See you there!


#5 of 6 arjunsud

arjunsud

    Advanced Member

  • PipPipPip
  • 53 posts
  • Join Date: Jan 02 2013

Posted January 19 2013 - 06:00 AM

Thank you guys !!! I really appreciate the help!! It turned on after about an hour actually . I suspect that it overheated? I'm going to give it 1 more go to see if it happens again and if so , off to epson it shall go!

#6 of 6 Gregg Loewen

Gregg Loewen

    Video Standards Instructor, THX Ltd.

  • 6,309 posts
  • Join Date: Nov 09 1999
  • Real Name:Gregg Loewen
  • LocationNew England

Posted January 20 2013 - 02:07 PM

dont worry about it. (as long as you are under warranty). I sell a TON of Epson projectors and they give best in class customer service.

The Sonodome - circa 2001
The Newest Sonotube - circa 2001
Gregg's DVDs updated...sometimes
Lion Audio Video Consultants usually current





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users